I have a file citea123.bib containing my bibliography, which I would like to include in my file test123.tex. I cannot get my bibliography to appear and cannot figure out why. I realize this question has been posted before, and I have tried using the suggested solutions (linked below) unsuccessfully. The mini-example below produces a .pdf document that does not contain the bibliography; the document produced is just below.

example document

First, the .bib file.

@article{MainAuthor et al., 
    author = {LastName1, F1.; LastName2, F2.; LastName3, F3.},
    title = {Title of Resource},
    journal = {Some Journal},
    volume = {123},
    number = {4},
    pages = {5-6},
    year = {2018},
    month = {01},
    doi = {https://doi.org/somenumbers}

Next, the .tex file. Below is the preamble.




    backend = biber,
    style = apa,




\title{This Is My Document Title}
\author{LastName1, F1.; LastName2, F2.; LastName3, F3.}

Now the main part of the .tex file.


My abstract goes here. Bla bla bla.


    \item Point A
    \item Point B
    \item Point C

The rest of this paper is organized as follows. Bla bla bla.



As seen in \cite{MainAuthor et al.}, our data looks like bla bla bla.






I am not sure what my error is and have tried many approaches without any luck. I've also configured my TexMaker settings, as suggested by answers in this post and this post and this post, as shown below.

example settings config p1

example settings config p2

I am using Texmaker 5.0.2 (compiled with Qt 5.9.1) on MacOS High Sierra version 10.13.6.

  • 3
    The entry key can't contain spaces. So instead of @article{MainAuthor et al., and \cite{MainAuthor et al.} you should say@article{mainauthor, and \cite{mainauthor}. Note also that names must be separated with and regardless of the desired output, so author = {LastName1, F1.; LastName2, F2.; LastName3, F3.}, should be author = {LastName1, F1. and LastName2, F2. and LastName3, F3.},, see tex.stackexchange.com/q/36396/35864. Fix these two issues, delete all temporary files (.aux, .bbl, .bcf, ...) and recompile with LaTeX, Biber, LaTeX, LaTeX.
    – moewe
    Commented Jun 10, 2019 at 11:43
  • Thanks. I tried changing it to MainAuthorEtAl, but it still does not work. I also get the error LaTeX Warning: Citation 'MainAuthorEtAl on page 1 undefined on input line 65.` LaTeX Warning: Empty bibliography on input line 71.
    – user173248
    Commented Jun 10, 2019 at 11:47
  • 2
    You need to change this in both the .bib and the .tex file. You also need to change the ; to and. Since old data might live on in the temporary files you should delete all auxiliary files and recompile from scratch. If even after LaTeX, Biber, LaTeX, LaTeX the issue remains, post the complete .blg and the relevant bits of the .log file here, please.
    – moewe
    Commented Jun 10, 2019 at 11:49
  • This solved my problem. Thank you!
    – user173248
    Commented Jun 11, 2019 at 2:51

1 Answer 1


There are two issues here.

  1. Entry keys can't contain spaces. @article{MainAuthor et al., won't work, you need something like


    instead. See also Can I have a reference with spacing using bibtex? Like \cite{Author Year}. More restrictions for the entry keys are discussed at Using BibTeX keys containing parentheses with Biber, What characters are allowed to use as delimiters for BibTeX keys?, What is the difference between a biblatex literal and string?.

  2. Regardless of the desired output multiple authors must always be separated with the keyword and. So author = {LastName1, F1.; LastName2, F2.; LastName3, F3.}, should be

    author = {LastName1, F1. and LastName2, F2. and LastName3, F3.},

    See How to properly write multiple authors in bibtex file?. If you input the names not with and but separate them with commas or semicolons Biber may complain or crash - or just parse the name incorrectly.

With those two issues fixed the code produces a citation and bibliography entry as expected.

You must log in to answer this question.