0

This question already has an answer here:

I am using the following template in order to create a letter

\documentclass[version=last]{scrlttr2}
\usepackage[ngerman]{babel}
\begin{document}

\begin{letter}{
  Petra Mustermann\\
  Vor dem Berg 1\\
  12345 Musterhausen
}
\opening{Liebe Vereinsvorsitzende,}
\end{letter}
\end{document}

I would like to have the date to be in german, but the date in the output is in english, as shown in the following picture. enter image description here On page 179 of the documentation of the package scrlttr2, the date is correctly printed in german. I am using Linux and pdflatex.

marked as duplicate by egreg, Phelype Oleinik, Mensch, schtandard, Dox Jun 11 at 12:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    It says 11. Juni 2019 for me, when compiling using TeXLive 2019 (also on linux) – daleif Jun 11 at 10:20
  • I tried with several releases of TeX Live, always getting “11. Juni 2019”. Do you get error messages or warnings? – egreg Jun 11 at 10:34
  • @egreg No, what i did to solve the problem was to follow the answer given here: tex.stackexchange.com/questions/157172/ngerman-sty-not-found – peer Jun 11 at 10:51
  • 1
    @egreg The problem is solved by installing texlive-lang-german as in your link, however I believe the “symptoms” are different here, where the OP wasn't trying to load ngerman.sty. As far as I can tell, the OP here should have seen a warning about missing ngerman.ldf, namely ! Package babel Error: Unknown option ngerman'. Either you misspelled it (babel) or the language definition file ngerman.ldf was not found.` – frougon Jun 11 at 11:35
  • @frougon The warning was certainly issued. But texlive-lang-german provides all is needed, including the obsolete ngerman.sty. – egreg Jun 11 at 11:40
0

Here is what i did to get the correct date (see here).

Open a terminal (ctrl + alt + t) and run the following commands:

sudo add-apt-repository ppa:texlive-backports/ppa
sudo apt-get update
sudo apt-get install texlive-lang-german
sudo apt-get upgrade
  • Is it really necessary to add a PPA for texlive-lang-german? – frougon Jun 11 at 10:56
  • What is one strage link.... – daleif Jun 11 at 10:56
  • @daleif Indeed, it's invalid: it is the URL-encoding of the text corresponding to the commands... – frougon Jun 11 at 11:01
  • @frougon I think it is not necessary. In order to test it, i removed the repository and texlive-lang-german, did an update and successfully reinstalled texlive-lang-german. – peer Jun 11 at 11:09
  • @peer The problem is, we don't know which packages your apt-get command installed or upgraded. This is probably recorded in /var/log/apt (I use aptitude, not apt-get). You might want to use apt-show-versions | grep "newer than version in archive" to see if you still have packages that are not yet in your now-current release... – frougon Jun 11 at 11:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.