0

I am getting the error:

'mgs.exe' is not recognized as an internal or external command, operable program or batch file.

when I run latex->ps->pdf on TeXnicCenter editor where I use Miktex 2.9 and my operating system is Windows 7

I checked mgs.exe ghost script and it exist in bin folder of Miktex

Can any one help me please?

1

MGS (MiKTeX GPL Ghostscript 9.25) is an integral part of MiKTeX and if that is not working then many other parts will likely fail

The problem is very common and the solution is very well known but not easy for those who trust that if its windows it must work.

The message you see is that the MiKTeX binary commands are not accessible via the core historic method of calling commands via comspec. (lots of Jargon)

Bottom line the folder with the binary executable files MUST be added by the installer to the System Environment path. So either the installer failed or you needs a machine restart or you did not have good instructions to follow.

Avoid (at this time) using the command line to set or setx or path the folder since at this stage any one of those attempted locally could make matters worse later.

It is easy to rectify, find out the location for your windows where the "path" is stored for use during reboot and add or correct the MiKTeX\bin folder there.

Windows 7 or 8 or 10 all use the same location within control panel advanced system settings even if it may look a bit different getting there.

enter image description here

Once its set in the system location correctly it will work for all user applications, so reboot the machine to test that it will always be available from now on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.