Since a good picture is better than a long text, here is the problem: alt text

And here is most of my Latex file up to this point:

\usepackage[francais, english]{babel}

% Margins
\usepackage[left=4cm, right=2cm, top=3cm, bottom=2cm]{geometry}

% Nomenclature -> List of Abbreviations
\renewcommand{\nomname}{List of Abbreviations}

% Make magic URL
    pdfborder = {0 0 0 0}

% APA style referencing

% Hack for URL serif font formating
\renewcommand{\url}[1] { \urlstyle{same}\oldUrl{#1} }

% ToC & Abbreviations in the ToC

% Widows & Orphans



% --------------------------Table of Contents--------------
\renewcommand{\contentsname}{Table of Contents}

% --------------------------List of Abbreviations----------
\printnomenclature[3 cm]

% --------------------------List of Figures-------------------

Do you have any idea what is going on with the line spacing?

  • 2
    Could you provide a minimal example that reproduces the problem? Do you really need to load all those packages to get the bug to kick in? Jul 28, 2010 at 17:20
  • 2
    In addition to Juans comment I would suggest that your example should compile without further edits. So if I copy your example into my editor and compile it, it should produce the output you wish,
    – qbi
    Jul 28, 2010 at 17:57
  • Maybe this could be taken to the meta. In a sense how should (minimal) examples be, so best answers are possible. Jul 28, 2010 at 22:51
  • @Nils: I'm not trying to silence any discussion, but I do think the notion of a minimal example is straightforward. It is an example which: 1) will actually compile as given on any standard tex system, and 2) contains only that which is necessary to reproduce the behaviour exemplified.
    – vanden
    Jul 29, 2010 at 14:59
  • @vanden: I totally agree, but maybe it is a topic that should be addressed in meta, or maybe taken into the FAQs. Jul 30, 2010 at 11:11

2 Answers 2


After much trying to replicate the behavior in a "minimal example", I actually found out what is happening. First let me say that I tried both ways: trying to recreate the behavior from scratch by adding bricks, and trying to provide a minimal example by removing bricks from my original document.

Finally, and sort of thanks to this other question, I found out that my "behavior" is not actually a bug, but a feature! In fact, what you can't really guess from my picture up there, is that all my figures were in the same chapter (document class is "book"), while all tables are in different chapters. Hence the line spacing for the tables, but not the figures, which symbolizes the chapter changes.

Anyway, sorry for bothering you and for not getting back to you earlier. Now I am going to try and see how I can add a line space between all figures and tables, independently from the fact that they are in the same chapter or not.

  • 3
    We should eventually add this to the faq, including some hints on how to build minimal examples. I can give you some preview: usually the removing bricks option works best; also usually, as you did, it is pretty common that you find the cause of your problem just by trying to build a minimal example. Jul 29, 2010 at 19:44

On my system, appending the following to your example




produces a document where spacing between lines are all fine. Please do try to build a minimal and complete example that reproduces the bug.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .