36

For my thesis, I use biblatex for the bibliography.

As seen here, biblatex is not compatible, with \usepackage[utf8x]{inputenc}. It was reported as close but I still have the same problem with my version of bibtex (last one on archlinux 2011.24688-1). I want to use the € symbol inside my report but it fails without utf8.

! Package biblatex Error: Incompatible package 'ucs'.

See the biblatex package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              

l.7 \begin{document}

Any idea idea how to fix ?

\documentclass{report}

\usepackage[utf8x]{inputenc}
\usepackage{biblatex}
\bibliography{includes/mybib}{}

\begin{document}

X said Y \cite{bib1}

\printbibliography

\end{document}

and the file mybib

@online { bib1,
       title = {Refrence title},
       author = {X},
       url = {http://site.com/y}}
1

3 Answers 3

35

Don't use utf8x. Load the TS1-encoding e.g. through textcomp and if you don't like the euro you get with textcomp change the definition of \texteuro. E.g.:

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\usepackage{eurosans}

\begin{document}
€  \let\texteuro\euro €
\end{document}
1
  • 1
    File 'eurosans.sty' not found. ^^M
    – Orion
    Jun 2, 2017 at 9:18
32

The utf8x option for inputenc is (probably) the issue here. Try just

\usepackage[utf8]{inputenc}

and you should be fine (as detailed in the biblatex manual).

0

As also explained in the biblatex documentation, you can use an TeX engine which is compatible with Unicode directly, like XeTeX or LuaTeX. For example XeTeX assumes the input is UTF-8 by default

If you use these, you don't need (and you should not use) the inputenc package

You can find more about the differences among these 3 in the LuaTeX page or in this response

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .