1

I'm running biber on a new MacBook Pro, and I am struggling to understand the errors I'm getting. When I try to run biber on a beamer handout, I get the following errors:

Running `Biber' on `handout' with ``biber handout''
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LC_ALL = (unset),
    LANG = "en_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
INFO - This is Biber 2.12
INFO - Logfile is 'handout.blg'
INFO - Reading 'handout.bcf'
INFO - Found 0 citekeys in bib section 0
WARN - The file 'handout.bcf' does not contain any citations!
INFO - Writing 'handout.bbl' with encoding 'UTF-8'
INFO - Output to handout.bbl
INFO - WARNINGS: 1

Can anyone help me understand these? Here's an example of a test document

\documentclass[12pt,a4paper]{article} % or whatever

\usepackage[
backend=biber,
        bibstyle=biblatex-langsci-unified,
        useprefix=true,
        citestyle=langsci-authoryear-comp,
        maxcitenames=3,
        maxbibnames=99]{biblatex}

\addbibresource{bib.bib}

\begin{document}

This is a test \parencite{kutschlojenga94}.

\printbibliography
\end{document}

And the bib.bib file contains

@Article{kutschlojenga94,
  author =   {Kutsch Lojenga, Constance},
  title =    {Kubudu},
  subtitle =     {A {Bantu} language with nine vowels},
  journal =      {African Languages},
  year =     1994,
  volume =   9,
  pages =    {127--34}}

UPDATE: Thanks to those that have been helping. I've added the \addbibresource{bib.bib}. After running LaTeX, biber, LaTeX, LaTeX the .blg file reads

[0] Config.pm:304> INFO - This is Biber 2.12
[0] Config.pm:307> INFO - Logfile is 'test.blg'
[47] biber-darwin:315> INFO - === Tue Jul 16, 2019, 10:29:52
[71] Biber.pm:371> INFO - Reading 'test.bcf'
[158] Biber.pm:889> INFO - Found 0 citekeys in bib section 0
[166] Utils.pm:193> WARN - The file 'test.bcf' does not contain any citations!
[173] bbl.pm:636> INFO - Writing 'test.bbl' with encoding 'UTF-8'
[173] bbl.pm:739> INFO - Output to test.bbl
[173] Biber.pm:110> INFO - WARNINGS: 1

The .tex, .bib, .blg, and .log files are available on github at https://github.com/JJSandstedt/Biber_issue_stack_exchange

  • 2
    en_DE.UTF-8 is a bit of an odd locale (the English spoken in Germany ...) and so it does not surprise me too much that the locale can not be found. A search for en_DE.UTF-8 leads to askubuntu.com/q/710955/57634, which explains what is going on. There is also stackoverflow.com/q/44243909 and stackoverflow.com/q/9991603 which mention some issues with locales specifically on a Mac. I don't have a Mac, so I can't test, but you may want to double check your system language/locale settings. ... – moewe Jun 17 at 18:45
  • ... It would also help if you could provide a minimal example document that you are running. If my hunch is right the locale warning could be benign, but maybe more things go wrong if the locale can't be set ... – moewe Jun 17 at 18:46
  • Your system is not correct configured. If you are Linux or macOS then run in. a terminal export LANG=de_DE.UTF-8. and then run biber in the same terminal. – user187802 Jun 18 at 7:05
  • Any news here? Could you find out if the error message has any actual relevance? Did you try changing your system locale or define en_DE.utf8? – moewe Jun 25 at 6:15
  • I have changed the language in system preferences to UK English, and so now it doesn't complain about the locale, but it still always fails to find citekeys. I'm new to this and useless at things with the terminal. – user9974638 Jun 26 at 8:09
0

The

perl: warning: Setting locale failed.

is most likely due to your unusual locale settings. You have

en_DE.UTF-8

which would be "the English spoken in Germany" (or English language with German localisation). Quite probably your system does not have locale definitions for those settings.

Googling for this and similar issues one finds amongst others https://askubuntu.com/q/710955/57634, https://stackoverflow.com/q/44243909 and https://stackoverflow.com/q/9991603.


The issue should go away if you select a locale in your language/locale settings that can actually be found (for example US English, UK English, German (Germany) etc.). If you want to stick to en_DE.utf8 you probably need to define the locale, see the previous links. In any case I expect little problems from this as long as the sorting locales that Biber needs can be found (usually those are selected from the document settings and so your generic settings should not matter).

  • Thanks for this. I don't care to keep the en-DE.utf8 locale setting. That's just how this computer came. I'd gladly just have UK English, but how do I change the locale setting? Apparently changing the language settings in System Preferences isn't enough? – user9974638 Jun 27 at 16:44
  • @user9974638 Sorry, I don't own a Mac and can't give you system-specific advice. Did you consider asking at apple.stackexchange.com? – moewe Jun 27 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.