0

In the most recent version I stumbled upon a small error that is maybe not so hard to fix, but I am unable to do it.

When setting the option style=casual

This gets passed down to (I think) hyperref and hence bookmark, which then reports an error that casual is not a valid style. The exact error message is

Latex Error: /usr/local/texlive/2019/texmf-dist/tex/latex/oberdiek/bookmark.sty:619 Package bookmark Error: Undefined style `casual’.

(running MacTeX2019 with all packages up to date)

For now I only solved it by copying your komacv.cls into my CV-folder and setting the default to casual, then it does not get passed down to bookmark.

How can I fix this error in the class itself (i.e. avoiding passing down style)?

2

You can prevent the error like this:

\documentclass[style=casual]{komacv}
 \makeatletter\providecommand\BKM@style@casual{}\makeatother
 \usepackage{bookmark}
 \begin{document}
 blblb
 \end{document}

It is imho an error from bookmark to fail over such document options. There is an open issue for it: https://github.com/ho-tex/oberdiek/issues/67. The code will be changed soon (actually I thought I had already done it ;-().

  • neat! Thanks for the info. That fixes my CV for the moment :) – Ronny Jun 19 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.