4

(1) I’d like to use an long Emacs + Org-mode + Beamer file (.org) to export a long slide. The .org file is about 100 pages, the slide will goto about 500 pages. So I would like to make the export directly by the .org file and not insert/modify the output .tex file.

(2) However, I met the auto-break problem when I tried to export it. (3) I used the command of: M-x org-beamer-export-to-pdf to generate the slide

(4) The configuration in the front of my .org file is as follow:

#+TITLE:  A long content Org-mode Beamer PPT export test

#+AUTHOR: test                      

#+LaTeX_CLASS_OPTIONS:[presentation,professionalfonts,compress,smaller,aspectratio=169]  

#+BEAMER_HEADER:\institute{test}                                               

#+PROPERTY: comments yes                                                                                          

#+PROPERTY: header-args :exports both :eval never-export 

#+BEAMER_COLOR_THEME: default                                                                                                  

#+BEAMER_THEME:CambridgeUS                                                                                             

#+BEAMER_INNER_THEME: default                                                               

#+COLUMNS: %45ITEM %10BEAMER_ENV(Env) %10BEAMER_ACT(Act) %4BEAMER_COL(Col)                            

#+LATEX_HEADER:\usepackage{xeCJK,fontspec,xunicode,xltxtra}                                                                 

#+LATEX_HEADER:\setCJKmainfont[Scale=0.98]{Yuanti SC Light}                                                                   

#+LATEX_HEADER: \AtBeginSection[]{\begin{frame}<beamer>\frametitle{Topic}\tableofcontents[currentsection]\end{frame}}

#+BEAMER_HEADER: \definecolor{links}{HTML}{0000A0}                                                                    

#+BEAMER_HEADER: \hypersetup{colorlinks=,linkcolor=,urlcolor=links}                                                  

#+BEAMER_HEADER: \setbeamertemplate{itemize items}[default]                                                                    

#+BEAMER_HEADER: \setbeamertemplate{enumerate items}[default]                                                       

#+BEAMER_HEADER: \setbeamertemplate{items}[default]                                                                        

#+BEAMER_HEADER: \setbeamercolor*{local structure}{fg=darkred}                                                        

#+BEAMER_HEADER: \setbeamercolor{section in toc}{fg=darkred}                                                                 

#+BEAMER_HEADER: \setlength{\parskip}{\smallskipamount}                                                                     

#+OPTIONS:H:3 num:t toc:t \n:nil @:t ::t |:t ^:t -:t f:t *:t <:t

(1) I have tried to put

allowframebreaks in #+LaTeX_CLASS_OPTIONS:, #+OPTIONS:, #+latex_header:. All of them do not work

(2) I have tried to insert:

:PROPERTIES:

:BEAMER_opt: allowframebreaks,label=

:END:

after each section, subsection, subsubsection title. Just part of the content can work and broke into the following slide, the rest were not work properly.

(3) Even I can not get the table- of-content displayed on the front of the Slide in this configuration

(4) I tried to delete :eval never-export in #+PROPERTY, but still not work

Thanks a lot!

1
  • anyone could help to check it? Thanks a lot!
    – saga
    Commented Jun 20, 2019 at 1:53

2 Answers 2

3

From https://github.com/fniessen/refcard-org-beamer

** A very long "frame" with breaks
:PROPERTIES:
:BEAMER_opt: allowframebreaks,label=
:END:

Works just fine for me for bibliographies and similar sections

1

From https://github.com/fniessen/refcard-org-beamer - the relevant option is this:

#+BIND: org-beamer-frame-default-options "allowframebreaks"
2
  • 1
    thanks... However,I have tried the #+BIND option. and is still not work... more ideas?
    – saga
    Commented Jun 19, 2019 at 15:44
  • @saga (setq org-export-allow-bind-keywords t)
    – Tokubara
    Commented Sep 9, 2022 at 4:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .