How to avoid the extra spaces in latex document, here i am facing the spacing from . to Kadokave, i am writing a large number of such texts assuming it may happen in some other lines also. Here is my MWE


 \usepackage{titletoc} %%% Table of contents 
   \fancyhead[LE,RO]{\leftmark} %% display chapter in header
   \fancyhead[C]{\thepage} %% To display numbering on every page alternately left and right

 \usepackage[colorlinks, unicode]{hyperref}

            {.25ex \@plus.25ex \@minus.1ex}%
  \setlength{\biblechapskip}{1em plus .33em minus .2em}
\advance\biblechap@svdopt by -1\fi
  \markright{{\scshape\currbook} \thebiblechapter:\thebibleverse}

 \newcommand{\jverse}[1]{\noindent\textcolor{cyan}{\scalebox{1.0}{\textbf{#1\hspace{1.0mm}}}}\markboth{\scshape\currbook\ \thejChapter : #1}{} }

 \newcommand{\BookLine}{ \centering\noindent\rule{19cm}{1pt}}
 \newcommand{\BookNote}[1]{{\begin{center} \textbf{KEPACHINI} \justify


 \newcommand{\ParallelLText}[2]{\begin{paracol}{2}\sloppy \switchcolumn[0]\noindent  #1 \switchcolumn[1]\noindent #2 \end{paracol}}

 \usepackage[perpage]{footmisc} %%% To restart footnote numbering on every new pages


 \setcounter{tocdepth}{2} %set depth of printed table of contets.


   {\leaders\hbox{\normalfont$\m@th\mkern \@dotsep mu\hbox{.}\mkern \@dotsep     mu$}\hfill}


 \makeatother %print dots in sections in toc.

 \renewcommand{\contentsname}{\hfill\Huge Kechejok Barim\hfill~\\[2.5ex] }

 \part*{\scshape Kechejok Barim}



 \part*{\scshape Kechejok Kemi}

 \renewcommand{\contentsname}{\hfill\Huge Kechejok Kemi\hfill~\\[2.0em]}


 \ParallelLText{\jverse{43}Kadokave atum Arnam ajakong pen apot manghuhak-lo. Kadokave atum Jisu keklembom akam aphan kemanghuphrong ahut alangli asangho atum aphan pulo.  }{\jverse{43}And all were astounded at the greatness of God. While everyone was amazed at all that he was doing, he said to his disciples, }

enter image description here

  • 1
    Please make your MWE really MWE (Minimal Working Example). Remove from preamble all what is not related to your problem (as page headers etc). – Zarko Jun 22 at 19:37
  • I am using all the packages which are in preamble, so i have to find the the commands or packages which compatible with my preamble, so i posted without reducing my preamble. @Zarko – Biki Teron Jun 22 at 19:45
  • 2
    Do all this packages relevant to your problem? If you say so ... but to me most of them is simple clutter for an MWE ... – Zarko Jun 22 at 19:49
  • To force all spaces, including the ones after punctuation, to be the same size, specify \frenchspacing in your preamble. However, in the example shown, a better approach would probably be to specify some additional hyphenation points in the word "kemanghuphrong". If there are no hyphenation patterns defined for this language, the best option is to look through the output, determine what words can best benefit from hyphenation and add a \hyphenation list to the preamble. The question tex.stackexchange.com/q/37934/579 may help (not sure). – barbara beeton Jun 22 at 20:06
  • Is the “left text” in Indonesian? You should use babel for it. – egreg Jun 22 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.