2

I can't use fontawesome5 in latex although installed in texlive-fonts-extra package. Here is the minimal example :

\documentclass[11pt,a4paper]{article}

\usepackage{fontawesome5}

\begin{document}

\faAddressBook

\end{document}

Compilation with latex is ok, but dvips complains :

mktexpk: don't know how to create bitmap font for fa5free1solid.
mktexpk: perhaps fa5free1solid is missing from the map file.

Where can I find fa5free1solid and how to add it to the map file ?

Thx for your help !

3

This is a bug in the packaging of old versions of fontawesome5 in TeX Live. You can either install a newer TeX Live version (newer versions are not packaged for your Ubuntu version, so you have to install them manually. See this great answer for detailed instructions. This option also gives you access to current versions of fontawesome5, the version in TeX Live 2017 is ancient.

Anyway, if you prefer to keep the TeX Live version installed through your package manager, you can add the missing map file manually by running

sudo updmap-sys --enable Map=fontawesome5.map

in a terminal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.