0

I'm in the process of typesetting my thesis, and I'm running into some trouble getting the chapters (which are actually papers) to look precisely the way I want. No matter what I do, I'm getting the abstract name indented.

I'm using the \abstractrunin option with Memoir, and if I read its documentation correctly, the "correct" way of removing this indentation should be with the command \setlength{\abstitleskip}{-\absparindent}. However, neither this, or any of my various attempts of adding \noindent and \ignorespaces to several commands have been fruitful.

Has anyone here had this issue before, and could perhaps give me a few helpful pointers? I'm at my wits' end.

See image below (blurred because I don't want to dox myself).

Infuriating indentation

1

I managed to solve my own problem, by finally resorting to looking at the implementation of Memoir in memoir.cls. I'm not too well versed in package programming, but I managed to find the following lines:

\AtBeginDocument{\setlength{\absparindent}{\parindent}
                 \setlength{\absparsep}{\parskip}}

The problem, of course, is that I was calling \absparindent in the preamble, before its value was set to the correct one. The abstract is correctly (not) indented now, after moving

\setlength{\abstitleskip}{-\absparindent}

to after \begin{document}. Feels like something that belongs in the preamble, but at least it works now.

Leaving this answer here, because I know how infuriating it is when I find a question with (edit: Solved it!) in it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.