3

After updating some packages I am receiving this error:

Error: can't read "::active_cls": no such variable

How can this be corrected? I uninstalled TeX Live and reinstalled, and received the same error.

  • I did have the same problem today with a fresh install of TeX Live on windows 10. The command line tool still works for me tough. So I'd say for you to use tlmgr in a terminal for the time being. – João Machado Jun 30 at 18:23
  • I have the same error and now it does not even open texlive manager. – azetina Jul 2 at 1:14
  • @DavidCarlisle Where are the installer files found so that I can replace it? Regards. – azetina Jul 2 at 18:11
  • @azetina that email link is all I know, sorry:-) – David Carlisle Jul 2 at 19:12
1

Thanks to David Carlisle, I was able to use the link he provided to do a quick patch of the files. Below are the steps to follow to fix the issue:

  1. Go to tug.org/texlive.
  2. Click on download and sources for the current release. This will take you to your closest CTAN mirror.
  3. Click on texlive/ then tlnet/ then tlpkg/ then tltcl/ and download the files.
  4. Replace these in your texlive 2019 folder in the sub directory C:\texlive\2019\tlpkg\tltcl.
1

I had the same error when trying to run TeXLive manager. It was solved by updating the manager through command line by the command

tlmgr update --self

If the above command does not solve the problem, try the following command

tlmgr update --all

this should clear and update the error causing packages.

0

I assume the problem occurs only with the GUI tlshell (Tcl/Tk-based) for tlmgr.

If you have java, I think the java-based tlcockpit (another GUI for tlmgr) under the directory \texlive\2019\texmf-dist\scripts\tlcockpit\tlcockpit.jar might be a better alternative.

Hope it helpful :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.