1

the problems with Mendeley and their bibtex exportation are numerous, but I am currently facing the following issue:

The Issue

For dissertations, my university requires to include the technical report number in citations. For the life of me, I can't get Mendeley to include this information in the bibtex file and now I have to include that info by hand for 20+ entries. I'm looking for a better way.

What I've tried so far:

  • In Mendeley, select document type Report
  • Include Number field within Mendeley (Preferences-> Document Details->Document Type = Report-> select Number)
  • Fill the field information by hand
  • Click Sync to create the new .bib file

Result:

Field number (number = {...}) does not appear in the generated .bib file

Current Workaround:

  • Generate the .bib fiel with Mendeley
  • Copy the generated .bib file
  • Open the copy with a text editor
  • Search for entry by hand
  • Add number = {...} by hand
  • Repeat

Looking for:

An automation for this, or an option in Mendeley to include Report Number information. Hacks welcome. Anything but to do it by hand!

Thanks!

  • Your write-up is not at all easy to follow. For instance, why are you not trying to create an entry of type @techreport? @techreport is a standard BibTeX entry type, whereas @report is not. – Mico Jul 2 at 10:53
  • Report is a Mendeley entry type which gets exported as @techreport in the BibTeX file generated automatically by Mendeley. As a user, I have no influence in naming or creating document types in Mendeley. – Nathan Folly Jul 3 at 9:07
0

Found the answer by accident. The field Issue below field year gets exported as number = {...} in the bibtex file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.