0

This question already has an answer here:

I'm struggling to make my German and English abstract appear on the same page in my report document. Currently they appear on two separate pages, no matter how big the abstracts get. Can anybody help me out? :)

The solution provided in here does not work, probably because I use a report instead of an article:

Command \abstract already defined. {\par\bigskip}

This solution here doesn't work because I need the titlepage environment.

EDIT (SOLUTION): Changing \newenvironment{abstract} to \renewenvironment{abstract} as suggested by Marijn did the job! Many thanks :) Also thank you for the suggestion on loading german as the last option to babel - I did that as well :)

\documentclass[11pt,a4paper]{report} 

% packages I use
\usepackage[german, english]{babel} 
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{textcomp}
\usepackage[hyphens]{url}
\input{../setup/hyphenations}
\usepackage{amssymb}
\usepackage{emptypage}
\usepackage{mathpazo}
\usepackage[scaled=.95]{helvet}
\usepackage{courier}
\usepackage[paper=a4paper,width=14.2cm,left=36mm,height=22cm]{geometry}
\usepackage{setspace}
\linespread{1.15}
\setlength{\parskip}{0.5em}
\setlength{\parindent}{0em}

\begin{document}

\begin{abstract} 
German Abstract
\end{abstract}

\selectlanguage{english}
\begin{abstract} 
English Abstract
\end{abstract}
\selectlanguage{german}

% some chapters / table of contents ...
\end{document}

marked as duplicate by Marijn, Raaja, Phelype Oleinik, barbara beeton, user170109 Jul 3 at 15:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Or possibly tex.stackexchange.com/questions/118218/… is a better duplicate (because it uses report). – Marijn Jul 3 at 13:21
  • Edited my original question :) – Lexusminds Jul 3 at 13:25
  • Ok, I'll see if I can find another solution then. – Marijn Jul 3 at 13:28
  • Please make sure the MWE does not depend on resources we do not have access to (for example are the three lines with \input needed`? – daleif Jul 3 at 13:29
  • 1
    Try \renewenvironment{abstract} instead of \newenvironment{abstract} in the first duplicate, as suggested in the comments there for article. I just tried it and that works also for report. – Marijn Jul 3 at 13:32
-1

Changing \newenvironment{abstract} to \renewenvironment{abstract} as suggested by Marijn did the job! Many thanks :) Also thank you for the suggestion on loading german as the last option to babel - I did that as well :)

  • Probably better to ask Marijn to provide an answer and then accept that. – daleif Jul 3 at 13:42
  • I'd appreciate that :) Just wanted to provide one for now if someone stumbles across this thread. – Lexusminds Jul 3 at 13:43
  • Hm, I think it would be best to close as duplicate and not have an answer here at all - the \renewenvironment modification is also mentioned by egreg as a comment to his answer to the duplicate. – Marijn Jul 3 at 13:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.