1

I am using apacite with the natbibapa option and I encountered some interesting behaviour regarding the use of et al. The MWE below shows that normally, 'firstauthor et al' is used in citiation call-outs to pieces with six or more authors. However, when another entry by (a few of) the same authors in the same year is added, the 'et al' only appears after the fourth author (uncomment \citep{article2} to see this result).

My question is: how do I get apacite to employ 'et al' in citation call-outs in case of more than six authors, regardless of the presence of other articles by the same authors?

\documentclass{article}
\usepackage[natbibapa]{apacite}
\bibliographystyle{apacite}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@misc{article1,
  title  = {Article title},
  author = {Author, Anna and Buthor, Bertha and Cuthor, Christine 
            and Duthor, Donna and Euthor, Erica and Futhor, Fay},
  year   = 2019,
}
@misc{article2,
  title  = {Article title},
  author = {Author, Anna and Buthor, Bertha and Cuthor, Christine},
  year   = 2019,
} 
\end{filecontents}

\begin{document}   
\citep{article1}

%\citep{article2}

\bibliography{\jobname}
\end{document}

Et al after first author


Et al after fourth author

1

(too long for a comment, hence posted as an answer)

Here's an excerpt from p. 13 of the user guide of the apacite package:

When citing a work with one or two authors, all authors are included in each citation [call-out]. When citing a work with six or more authors, only the first author's name is included in the text, followed by "et al.". With three to five authors, the full list is included the first time the work is cited, and only the first with "et al." in subsequent citations.

There are some special cases, where some of the authors and the year are the same, but not the whole author list, in which more names are retained on subsequent citations as well. Section 13 includes some examples of complex situations and how to deal with them. All of this is automatically handled by apacite.

In short, the behavior you've documented in your query is exactly what apacite is meant to be doing. If you deviate from any of the settings of the apacite package, you are also automatically non-compliant as far as the APA style and formatting guide is concerned.

If you do not like this setting, you must provide some explicit suggestions for how one (or BibTeX) should distinguish between a piece published by "Author, Anna and Buthor, Bertha and Cuthor, Christine" in 2019 and another piece, by "Author, Anna and Buthor, Bertha and Cuthor, Christine and Duthor, Donna and Euthor, Erica and Futhor, Fay", also published in 2019. A commonly chosen solution is to affix "a", "b", etc to the year; however, you've made no such indication, and I certainly do not wish to be presumptuous.

Rather than engage in an almost certainly very complicated hack of the apacite package and the apacite bibliography style, I suggest you switch to a different bibliography style altogether. A candidate alternative might be elsarticle-harv, which requires the natbib citation management package.

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{\jobname.bib}
@misc{article6,
  title  = {Further thoughts},
  author = {Author, Anna and Buthor, Bertha and Cuthor, Christine 
            and Duthor, Donna and Euthor, Erica and Futhor, Fay},
  year   = 2019,
}
@misc{article3,
  title  = {Thoughts},
  author = {Author, Anna and Buthor, Bertha and Cuthor, Christine},
  year   = 2019,
}
\end{filecontents}

\documentclass{article}
\usepackage{geometry,parskip} %optional
\usepackage[authoryear]{natbib}
\bibliographystyle{elsarticle-harv}

\begin{document}   
\citet{article6}

\citet{article3}
\bibliography{\jobname}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.