0

I am using biblatex with phys citation style. And I would like to keep this citation style, but in the bibliography list the entries come out like that:

enter image description here

i.e. as exponents. I would like to keep the style the same, but only have the numbers in the list like [23]...

Is this possible?


The part of the code where I set stuff is:

\usepackage[
    backend=bibtex, 
    natbib=true,
    giveninits=true,
    style = phys,
    citestyle = numeric-comp,
    sorting = none,
    doi=false,
    url=false,                     % excluded from citations below
    %citecounter=true, citetracker=true,
    block=space, 
    backref=true, backrefstyle=two,
    abbreviate=false,
    isbn=false,
    hyperref = true
]{biblatex}
\AtEveryBibitem{%
  \clearlist{language}%
}
\addbibresource{phd_thesis_corr.bib}
1

The biblatex-phys style has an option for that. It's called biblabel and is explained briefly in the biblatex-phys documentation.

\usepackage[
    backend=bibtex, 
    natbib=true,
    style=phys,
    biblabel=brackets,
    giveninits=true,
    abbreviate=false,
    doi=false, url=false, isbn=false,
    block=space,
    backref=true, backrefstyle=two,
]{biblatex}

If you just load style=phys without citestyle=numeric-comp,, you can drop the explicit sorting=none, since phys sets this option automatically.

You may want to consider using Biber instead of BibTeX to harness the full power of biblatex. See Biblatex with Biber: Configuring my editor to avoid undefined citations.

For most people the option hyperref=true is not better than the default hyperref=auto. In particular hyperref=true on its own will not turn on links, you still have to load the hyperref package manually. The only difference to hyperref=auto is a warning in case you failed to load hyperref.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.