1

I am making a .bib file and the citations are working well using @article. While using @inproceedings and @misc, I am getting one '(' in the reference.

@inproceedings{Aggarwal06,
   author={Aggarwal, Gagan and Hartline, Jason D.},
   year={2006},
   title={Knapsack auctions},
   booktitle={Proceedings of the 17th Annual ACM-SIAM Symposium on Discrete Algorithms},
   pages={1083-1092},
   publisher={Association for Computing Machinery},
   address={New York}
}

The result is coming out to be:

Aggarwal, G., Hartline, J.D. ‘Knapsack auctions’. In: Proceedings of the 17thAnnual ACM-SIAM Symposium on Discrete Algorithms. (New York: Associationfor Computing Machinery, 2006. pp. 1083–1092.

Notice the '(' before New York.

I am using IET Trans format. So, using iet.bst file for bibliography style. Following is the link that I am using: github.com/mairasaboia/ratProj_animalBiometrics_iet_journal

Could anyone suggest how to get rid of this?

4
  • Could you provide a minimal example? Would be useful to see the natbib options and the bibliography style you are using.
    – jorgepz
    Commented Jul 12, 2019 at 1:35
  • Thanks. I am using IET Trans format. So, using iet.bst file for bibliography style. Following is the link that I am using: github.com/mairasaboia/ratProj_animalBiometrics_iet_journal
    – God_Help
    Commented Jul 12, 2019 at 1:49
  • File iet.bst has a bug. Please make a bug report to the maintainer ...
    – Mensch
    Commented Jul 12, 2019 at 2:34
  • Thanks a lot for pointing out. I have been able to make the correction by adding output.check in the both the entries: @ inproceedings and @ misc. The problem is resolved. I would notify the maintainer to make the edits.
    – God_Help
    Commented Jul 12, 2019 at 3:13

1 Answer 1

1

A complete solution consists of contacting the author/maintainer of the iet bibliography style.

Assuming that you don't want or need the ( symbol before the address field, a temporary fix is available as follows. (Aside: If you do want to keep the opening parenthesis and wish to have a closing parenthesis immediately after the year field, I suggest you follow the instructions provided in this earlier answer.)

  • Make a copy of the file iet.bst and call the copy, say, iet-fixed.bst. (Don't modify iet.bst directly.)

  • Open the file iet-fixed.bst in a text editor; the program you use to edit your tex files will do fine.

  • In iet-fixed.bst, search for the following line:

    FUNCTION {format.org.or.pub}
    

    Two lines down from that line, you should find the following line:

    "("
    

    Change it to

    " "
    

    i.e., change the opening parenthesis to a space character.

  • Save the file iet-fixed.bst either in the directory where your main tex file is located or in a directory that's searched by BibTeX. If you choose the latter option, be sure to update the filename database of your TeX distribution suitably.

  • In your main tex file, change the instruction \bibliographystyle{iet} to \bibliographystyle{iet-fixed}. Then, perform a full recompile cycle -- LaTeX, BibTeX, and LaTeX twice more -- to propagate all changes.

Happy BibTeXing!


Here's the output from a full MWE (minimum working example):

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{mybib.bib}
%% Source of the following information:
%% https://dl.acm.org/citation.cfm?id=1109677
@inproceedings{Aggarwal06,
  author       = "Aggarwal, Gagan and Hartline, Jason D.",
  title        = "Knapsack Auctions",
  booktitle    = "Proceedings of the Seventeenth Annual
                  ACM-SIAM Symposium on Discrete
                  Algorithms (SODA)",
  year         = 2006,
  isbn         = "0-89871-605-5",
  location     = "Miami, Florida",
  pages        = "1083--1092",
  numpages     = 10,
  url          = "http://dl.acm.org/citation.cfm?id=1109557.1109677",
  acmid        = 1109677,
  publisher    = "SIAM",
  address      = "Philadelphia",
}
\end{filecontents}

\documentclass{article} 
\bibliographystyle{iet-fixed}
\usepackage{xurl}
\usepackage[colorlinks,allcolors=blue]{hyperref} % optional

\begin{document}
\cite{Aggarwal06}
\bibliography{mybib}
\end{document} 

Not the answer you're looking for? Browse other questions tagged .