1

so for my academic paper I have one book to cite from which is written by brothers (P. Hüwe & S. Hüwe). The citation style my university wants is for to authors to be diveded by a slash: (Hüwe/Hüwe 2019).

This citation stlye works, but unfortunatly not in this particular case where both authors share the same last name, because it also prints out their first names.

Here is my code:

\documentclass{article}
\usepackage[style=authoryear,maxcitenames=2,maxbibnames=99]{biblatex}
\DefineBibliographyStrings{ngerman}{ 
   andothers = {{et\,al\adddot}},             
} 
\DeclareNameAlias{sortname}{last-first}

\addbibresource{biblatex-examples.bib}



\begin{document}
\begingroup
\renewcommand*{\finalnamedelim}{/}
\renewcommand*{\multinamedelim}{/}

normal document text

\cite{Hüwe.2019} \\Doenst work
\cite{Yerpude.2019} \\works


\endgroup
\printbibliography
\end{document}

Result:

Anyone knows why this is?

marked as duplicate by moewe biblatex Jul 14 at 14:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • See also tex.stackexchange.com/q/134535/35864 – moewe Jul 14 at 13:13
  • Note that the name format last-first has been renamed and that the preferred form would be \DeclareNameAlias{sortname}{family-given}. finalnamedelim and multinamedelim are also context sensitive nowadays so that you shouldn't have to work with redefinitions in the document body and \begingroup...\endgroup. – moewe Jul 14 at 13:15
4

The uniquename=false option takes care of this problem:

\documentclass{article}
\usepackage[style=authoryear,maxcitenames=2,maxbibnames=99, uniquename=false]{biblatex}
\DefineBibliographyStrings{ngerman}{ 
   andothers = {{et\,al\adddot}},             
} 
\DeclareNameAlias{sortname}{last-first}

\addbibresource{test.bib}


\usepackage{filecontents}
\begin{filecontents*}{test.bib}
@article{Huewe.2019,
    author = {Hüwe, P. and Hüwe, S.},
    title = {title},
    year = {2019}
}
\end{filecontents*}


\begin{document}
\begingroup
\renewcommand*{\finalnamedelim}{/}
\renewcommand*{\multinamedelim}{/}

normal document text

\cite{Huewe.2019} \\Doenst work



\endgroup
\printbibliography
\end{document}
  • Works, thanks! Unfortunatly, it does not within a table environment. do you have any clue why? – spqx Jul 14 at 14:13
  • @spqx If you use the option as shown in this answer it should work everywhere. That is to say \cite and related commands (not \fullcite and the bibliography) will not show given names or given name initials. If it turns out that despite the option you get to see given name initials in some situations, please reproduce this undesirable behaviour in an MWE and report it as a bug at github.com/plk/biblatex/issues – moewe Jul 14 at 14:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.