6
  • I updated MiKTeX yesterday.
  • pdflatex stopped to work (luatex is not affected).

enter image description here

The log file (C:\Users\manu\AppData\Local\MiKTeX\2.9\miktex\log\pdflatex.log) states:

2019-07-18 18:54:02,500+0200 INFO  pdflatex - starting with command line: pdflatex my_LaTeX_File.tex
2019-07-18 18:54:02,516+0200 INFO  pdflatex - allowing known shell commands
2019-07-18 18:54:02,516+0200 INFO  pdflatex - enabling input (output) from (to) processes
2019-07-18 18:54:02,516+0200 FATAL pdflatex - MiKTeX encountered an internal error.
2019-07-18 18:54:02,516+0200 FATAL pdflatex - Info: 
2019-07-18 18:54:02,516+0200 FATAL pdflatex - Source: Libraries\MiKTeX\Core\Session\config.cpp
2019-07-18 18:54:02,516+0200 FATAL pdflatex - Line: 526
2019-07-18 18:54:02,516+0200 INFO  pdflatex - finishing with exit code 1

My MWE looks like:

\documentclass{article}

\begin{document}

Test

\end{document}

Any ideas for a quick fix?


Update 1

  • I followed the advice from user "Bernard" and user "Mensch".
  • I got a new error: The MiKTeX configuration utility failed for some reason. The process output has been saved to a file.
  • The log file contains the following:

initexmf.log
----------
2019-07-19 12:30:07,559+0200 INFO  initexmf - starting: MiKTeX Configuration Utility 2.9.7076 (MiKTeX 2.9.7050 64-bit)
2019-07-19 12:30:07,559+0200 INFO  initexmf - Operating on the private (per-user) MiKTeX setup
2019-07-19 12:30:07,559+0200 INFO  initexmf - starting with command line: initexmf --dump=pdfetex
2019-07-19 12:30:07,559+0200 INFO  initexmf - running: miktex-makefmt.exe --engine=pdftex --dest-name=pdfetex --no-dump pdfetex.ini --engine-option=-tcx=cp227.tcx --miktex-disable-maintenance
2019-07-19 12:30:10,350+0200 ERROR initexmf - sub-process error output has been saved to 'C:\Users\manu\AppData\Local\MiKTeX\2.9\miktex\log\miktex-makefmt_2019-07-19-123010.out'
2019-07-19 12:30:10,350+0200 FATAL initexmf - The executed process did not succeed.
2019-07-19 12:30:10,350+0200 FATAL initexmf - Info: fileName="C:\Users\manu\AppData\Local\Programs\MiKTeX 2.9\miktex\bin\x64\miktex-makefmt.exe", exitCode="1"
2019-07-19 12:30:10,350+0200 FATAL initexmf - Source: 
2019-07-19 12:30:10,350+0200 FATAL initexmf - Line: 0

Maybe I just deinstall MiKTeX and try TeXLive.

enter image description here

enter image description here


Final Solution

Final Solution: I deleted MiKTeX and installed TeXLive.

5
  • 1
    Try rebuilding the formats.
    – Bernard
    Commented Jul 18, 2019 at 17:31
  • @Bernard Thanks. Do you mean the pdftex format (or refreshing file name data base)? I started building the pdftex format - it runs for about 15 min now and seems to be stuck (no CPU performance is used for it). I try again tomorrow. Commented Jul 18, 2019 at 20:10
  • 1
    No, not the filename database, just rebuild pdflatex.fmt (if you do run pdflatex) from MiKTeX Console, Settings, Formats tab.
    – Bernard
    Commented Jul 18, 2019 at 20:22
  • @Bernard Apparently there is a bigger problem (see update). Thanks for your effort. I guess that it's easier to delete MiKTeX. Commented Jul 19, 2019 at 10:35
  • 1
    Perhaps there was a problem at installation – this happens from time to time. Try uninstalling and re-installing and check the installation log file
    – Bernard
    Commented Jul 19, 2019 at 10:40

3 Answers 3

10

Well, rebuilding the format(s) is a little bit hiddden in MiKTeX Console:

miktex console

  1. Open MiKTeX Console (I have an admin installation, so I used admin mode)
  2. Click on Settings (red arrow, marked 1)
  3. Click on Formats (red arrow, marked 2)
  4. Scroll down to find pdflatex and click on it to mark it with the blue line (red arrow, marked 3)
  5. Click on Build format (red circle, marked 4)

That rebuilds the format for pdflatex. Seems that in your installation the run for that format building was faulty ...

Happend from time to time to me too, I always proof all engines after updating MiKTeX with a small test program for proper running ...

9
  • +1: Thanks. I will test it later Commented Jul 19, 2019 at 5:32
  • No luck (see Update) - apparently there is more wrong. I guess it's too hard so be solved here. Maybe it's easier to deinstall it. Commented Jul 19, 2019 at 10:35
  • 1
    @Dr.ManuelKuehner I would try to restart the update process. First reboot your computer, second restart updating MiKTeX. In most cases for my students that solved the issue, depends also on the state of Windows (more or less corrupted). Sometimes an aggrssive anti-virus-software can ibe the culprit ...
    – Mensch
    Commented Jul 19, 2019 at 10:50
  • 1
    @Dr.ManuelKuehner Do you have any news for us?
    – Mensch
    Commented Jul 22, 2019 at 14:28
  • 1
    @Dr.ManuelKuehner Well, I only was interested to hear the solution for this issue ... So no problem here, indeed ...
    – Mensch
    Commented Jul 22, 2019 at 16:19
2

I solved this by starting the MiKTex Console and doing the following steps:

  1. Go to Cleanup
  2. Choose to reset your local configuration

This will delete your local (user-level) configuration of MiKTex and apparently get me going again.

1
1

This may help someone:

In my case the event log got stuck at this point:

INFO  miktex-xelatex - this process (6743) started by 'texstudio' with command line: /Users/username/bin/miktex-xelatex
INFO  miktex-xelatex - allowing known shell commands
INFO  miktex-xelatex - enabling input (output) from (to) processes

Even after waiting for long, nothing happened after this.

When I checked my "Configure TexStudio" settings, they were like so: enter image description here

Then I changed it to the following: (check the Latex, Pdflatex, Xelatex commands) enter image description here (could be done easily by clicking the button circled in red above)

And voila! Things then worked normally!

The problem was with correctly formatting the commands and including filenames.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .