2

I have been using the verbose-ibid style and wondered if someone could let me know how to exclude ISBN numbers, language and publisher from footnotes, short of updating the corresponding biblatex file?

  • You can make it much easier for people to answer your question if you include a fully working example document that shows what you have so far. Do you also want to exclude the data from the bibliography at the end? – moewe Jul 21 at 12:56
  • re: the Bibliography, I'd not thought that far ahead, but yes, that would be ideal! Re: working example, I'm afraid I'm using a large biblatex file, which was created from my Zotero references, which makes it difficult to upload an example. I have tried to remove the information that I don't want to appear in the footnotes from the biblatex file and the corresponding Zotero entry, but this doesn't seem to have done the trick. – JTLaTex Jul 22 at 11:14
  • It would be enough to just show one example entry from the .bib file. But we definitely need to see what else is going on. I can work from your very good MWE from your other question (tex.stackexchange.com/q/500752/35864), but it would be a shame if I found a solution and then you told me it is incompatible with what you are doing because there is more going on in your document with biblatex than that example shows. – moewe Jul 22 at 16:04
1

For the isbn there is the global option isbn=false that you could use to suppress the output, but a similar option does not exist for most fields (e.g. publisher).

If you want the fields gone in the citations and the bibliography, the simplest option is to clear them out with a Biber sourcemap. That way they won't even reach biblatex. (See also Disable ISSN but keep ISBN with biblatex, Excessive fields in biblatex could not be removed if using \fullcite, Remove title in biblatex references, Problems in suppressing "series" field for more on suppressing fields.)

\documentclass[dutch]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[style=verbose-ibid, backend=biber]{biblatex}

\DeclareSourcemap{
  \maps[datatype=bibtex]{
    \map{
      \step[fieldset=isbn, null]
      \step[fieldset=language, null]
      \step[fieldset=publisher, null]
    }
  }
}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{nussbaum,
  author       = {Nussbaum, Martha},
  title        = {Aristotle's \mkbibquote{De Motu Animalium}},
  date         = 1978,
  publisher    = {Princeton University Press},
  location     = {Princeton},
  language     = {english},
  isbn         = {978-0691020358},
}

\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
\null\vfill
Lorem\autocite{nussbaum}
\printbibliography
\end{document}

Nussbaum, Martha. Aristotle’s „De Motu Animalium”. Princeton, 1978.

Note that the document language is set to a language other than english, because otherwise the clearlang option would automatically suppress the language = {english},.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.