0

I am using Pop!_os 18.04 LTS (which is based on Ubuntu 18.04) and I am trying to get program to run which makes heavy use of LaTeX. I am using the MiKTeX package manager to install the TeX packages that the program requires. I am stuck on trying to get this package dsfont to install. According to this answer, installing texlive-fonts-extra should have fixed it. I tried using sudo apt-get install texlive-fonts-extra and it installs correctly but the error still stands.

The same thread also explains how dstroke is the distribution package name in MiKTeX for dsfont. However, I cannot find a package named dstroke in MiKTeX. The search returns an empty list. The had suggested that a package named doublestroke was being used in TeX live for getting dstroke. So I tried searching for that in MiKTeX just in case and I was able to find it and install it. But that also did not fix the error. I cannot find any other pointer to installing this. Please help.

OS: Pop!_OS 18.04 (Similar to Ubuntu 18.04)
Python: 3.7.1
MiKTeX: MiKTeX Package Manager 2.9.7043 (MiKTeX 2.9.7050)

TeX error Log -

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (MiKTeX 2.9.7050) (preloaded format=latex 2019.7.21)  21 JUL 2019 22:41
entering extended mode
**./media/Tex/f4fdd6aabf2e43a0.tex
(media/Tex/f4fdd6aabf2e43a0.tex
LaTeX2e <2018-12-01>
(/home/ananda/.miktex/texmfs/install/tex/latex/standalone/standalone.cls
Document Class: standalone 2018/03/26 v1.3a Class to compile TeX sub-files stan
dalone
(/home/ananda/.miktex/texmfs/install/tex/latex/xkeyval/xkeyval.sty
Package: xkeyval 2014/12/03 v2.7a package option processing (HA)
(/home/ananda/.miktex/texmfs/install/tex/generic/xkeyval/xkeyval.tex (/home/ana
nda/.miktex/texmfs/install/tex/generic/xkeyval/xkvutils.tex
\XKV@toks=\toks14
\XKV@tempa@toks=\toks15
(/home/ananda/.miktex/texmfs/install/tex/generic/xkeyval/keyval.tex))
\XKV@depth=\count80
File: xkeyval.tex 2014/12/03 v2.7a key=value parser (HA)
))
\sa@internal=\count81
\c@sapage=\count82
(/home/ananda/.miktex/texmfs/install/tex/latex/standalone/standalone.cfg
File: standalone.cfg 2018/03/26 v1.3a Default configuration file for 'standalon
e' class
) (/home/ananda/.miktex/texmfs/install/tex/latex/base/article.cls
Document Class: article 2018/09/03 v1.4i Standard LaTeX document class
(/home/ananda/.miktex/texmfs/install/tex/latex/base/size10.clo
File: size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option)
)
\c@part=\count83
\c@section=\count84
\c@subsection=\count85
\c@subsubsection=\count86
\c@paragraph=\count87
\c@subparagraph=\count88
\c@figure=\count89
\c@table=\count90
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
) (/home/ananda/.miktex/texmfs/install/tex/latex/preview/preview.sty
Package: preview 2017/04/24 11.91 (AUCTeX/preview-latex)
(/home/ananda/.miktex/texmfs/install/tex/latex/preview/prtightpage.def
\PreviewBorder=\dimen103
)
\pr@snippet=\count91
\pr@box=\box27
\pr@output=\toks16
)) (/home/ananda/.miktex/texmfs/install/tex/generic/babel/babel.sty
Package: babel 2019/07/19 3.33 The Babel package
(/home/ananda/.miktex/texmfs/install/tex/generic/babel/switch.def
File: switch.def 2019/07/19 3.33 Babel switching mechanism
) (/home/ananda/.miktex/texmfs/install/tex/latex/babel-english/english.ldf
Language: english 2017/06/06 v3.3r English support from the babel system
(/home/ananda/.miktex/texmfs/install/tex/generic/babel/babel.def
File: babel.def 2019/07/19 3.33 Babel common definitions
\babel@savecnt=\count92
\U@D=\dimen104
(/home/ananda/.miktex/texmfs/install/tex/generic/babel/txtbabel.def)
\bbl@dirlevel=\count93
)
\l@british = a dialect from \language\l@english 
\l@UKenglish = a dialect from \language\l@english 
\l@american = a dialect from \language\l@english 
\l@canadian = a dialect from \language\l@american 
\l@australian = a dialect from \language\l@british 
\l@newzealand = a dialect from \language\l@british 
)) (/home/ananda/.miktex/texmfs/install/tex/latex/amsmath/amsmath.sty
Package: amsmath 2018/12/01 v2.17b AMS math features
\@mathmargin=\skip43
For additional information on amsmath, use the `?' option.
(/home/ananda/.miktex/texmfs/install/tex/latex/amsmath/amstext.sty
Package: amstext 2000/06/29 v2.01 AMS text
(/home/ananda/.miktex/texmfs/install/tex/latex/amsmath/amsgen.sty
File: amsgen.sty 1999/11/30 v2.0 generic functions
\@emptytoks=\toks17
\ex@=\dimen105
)) (/home/ananda/.miktex/texmfs/install/tex/latex/amsmath/amsbsy.sty
Package: amsbsy 1999/11/29 v1.2d Bold Symbols
\pmbraise@=\dimen106
) (/home/ananda/.miktex/texmfs/install/tex/latex/amsmath/amsopn.sty
Package: amsopn 2016/03/08 v2.02 operator names
)
\inf@bad=\count94
LaTeX Info: Redefining \frac on input line 223.
\uproot@=\count95
\leftroot@=\count96
LaTeX Info: Redefining \overline on input line 385.
\classnum@=\count97
\DOTSCASE@=\count98
LaTeX Info: Redefining \ldots on input line 482.
LaTeX Info: Redefining \dots on input line 485.
LaTeX Info: Redefining \cdots on input line 606.
\Mathstrutbox@=\box28
\strutbox@=\box29
\big@size=\dimen107
LaTeX Font Info:    Redeclaring font encoding OML on input line 729.
LaTeX Font Info:    Redeclaring font encoding OMS on input line 730.
\macc@depth=\count99
\c@MaxMatrixCols=\count100
\dotsspace@=\muskip10
\c@parentequation=\count101
\dspbrk@lvl=\count102
\tag@help=\toks18
\row@=\count103
\column@=\count104
\maxfields@=\count105
\andhelp@=\toks19
\eqnshift@=\dimen108
\alignsep@=\dimen109
\tagshift@=\dimen110
\tagwidth@=\dimen111
\totwidth@=\dimen112
\lineht@=\dimen113
\@envbody=\toks20
\multlinegap=\skip44
\multlinetaggap=\skip45
\mathdisplay@stack=\toks21
LaTeX Info: Redefining \[ on input line 2844.
LaTeX Info: Redefining \] on input line 2845.
) (/home/ananda/.miktex/texmfs/install/tex/latex/amsfonts/amssymb.sty
Package: amssymb 2013/01/14 v3.01 AMS font symbols
(/home/ananda/.miktex/texmfs/install/tex/latex/amsfonts/amsfonts.sty
Package: amsfonts 2013/01/14 v3.01 Basic AMSFonts support
\symAMSa=\mathgroup4
\symAMSb=\mathgroup5
LaTeX Font Info:    Overwriting math alphabet `\mathfrak' in version `bold'
(Font)                  U/euf/m/n --> U/euf/b/n on input line 106.
))

! LaTeX Error: File `dsfont.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

Enter file name: 
! Emergency stop.
<read *> 

l.7 \usepackage
               {setspace}

Here is how much of TeX's memory you used:
 2175 strings out of 494858
 28788 string characters out of 3178198
 96215 words of memory out of 3000000
 5854 multiletter control sequences out of 15000+200000
 3640 words of font info for 14 fonts, out of 3000000 for 9000
 0 hyphenation exceptions out of 8191
 34i,0n,56p,244b,36s stack positions out of 5000i,500n,10000p,200000b,50000s

No pages of output.
  • The package dsfont.sty is available as doublestroke in both MikTeX and TeX live (see ctan.org/pkg/doublestroke). Did you try installing that package via the MikTeX Console? You may want to remove texlive-fonts-extra and other packages that sudo apt-get install texlive-fonts-extra may have installed, since this probably installed another (possibly outdated) TeX live from the Ubuntu repositories on your system. – moewe Jul 21 '19 at 15:41
0

It is recommended that do not install TeXLive from Ubuntu repository. Get latest TexLive 2019 from CTAN repository and install it. First remove previous installed packages and MikTex.

‫sudo apt-get remove texlive-*

Go to the folder which you downloaded, and run the following command:

sudo perl install-tl --gui=perltk
|improve this answer|||||
  • The OP has already installed MikTeX for Linux. Installing another TeX system (vanilla TeX live) might cause more confusion than it does good. – moewe Jul 21 '19 at 15:27
  • @moewe Yes, you are right. But it could cause more problems later. It is better to remove all texlive compiler and install complete CTAN Texlive. – A Diyanat Jul 21 '19 at 15:35
  • I agree that removing the TeX live that was (inadvertently) installed by sudo apt-get install texlive-fonts-extra is probably a good idea, but I don't necessarily agree that the OP should install vanilla TeX live when they already have access to a reasonably up-to-date (and updatable!) MikTeX. The solution here would probably involved installing the package in MikTeX rather than demolishing everything and switching the TeX distribution. – moewe Jul 21 '19 at 15:38
  • But I think that the problem has raised is that the ANANDA tex editor uses MikTeX compiler, not the compiler which installed using 'sudo apt'. So installing texlive-fonts-extra does not help. As you suggested one way is to install some necessary packages using MikTeX package manager. – A Diyanat Jul 21 '19 at 15:53
  • As I wrote in my comment above I agree with that part of the analysis. But I disagree that the best course of action given the status quo is to remove MikTeX and install vanilla TeX live. Installing the correct package in MikTeX should be enough. – moewe Jul 21 '19 at 15:55
0

As a MiKTeX package it is known as doublestroke. Furthermore, it may happen that you have to launch updmap to refresh the type 1 fonts database:

enter image description here

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.