1

I am new to LaTeX. I have searched my question but I couldn't find solution.

When I export to PDF I am getting the error. ! Package inputenc Error: Unicode character (U+200E) (inputenc) not set up for use with LaTeX.

5
  • Does anybody know what the exact problem is?
    – asghar
    Commented Jul 21, 2019 at 14:58
  • 1
    U+200E is an invisible Left-to-Right Mark, maybe it appeared in the source due to copy-and-paste or a slip of the finger. The message should tell you the problematic line, so you should be able to find the problematic bit of code. w3c.github.io/xml-entities/unicode-names.html might help you to identify the issue.
    – moewe
    Commented Jul 21, 2019 at 15:03
  • 1
    I've see many pieces of code, apparently written with an editor set up for Arabic, with several instances of the character U+200E even when no Arabic is used. Check the preferences of your editor.
    – egreg
    Commented Jul 21, 2019 at 22:12
  • 1
    Does this question help: Package inputenc error unicode character − (u+200E)? Commented Aug 20, 2019 at 16:40
  • It can appears when compiling .Rnw files, specifically when R chunks return tibbles.
    – zabala
    Commented Sep 28, 2022 at 2:04

3 Answers 3

3

U+200E is the left-to-right mark, which you probably copied and pasted into your document from the Web. You should probably remove it in your text editor. If you are mixing different languages in your document, and want to keep the bidirectional mark, you probably want to load babel or polyglossia instead and use their commands to switch languages.

If you really, really want to keep it in there, though, and you’re absolutely forced to use PDFTeX, you might load bidi and set ^^^^200e as an active character.

1
  • Even "If you really, really want to keep it there" has two cases: (1) keep it there and have TeX treat it as left-to-right mark => what you said (load bidi and make it an active character); (2) keep it there and have TeX ignore it => \DeclareUnicodeCharacter{200E}{} Commented Aug 21, 2019 at 15:05
2

This was very difficult for me to debug, but there was a simple solution in the end. I had to copy the character from the easy copy/paste box from unicode-symbols.com

I pasted the character into search box in my text editor (I used visual studio code), and I found one instance of this invisible character. I just deleted it.

1

Compile your tex file with XeLaTeX instead of pdfLaTeX. For example, if you use TeXStudio as editor, go to the Options->Configure TexStudio->Build->Default Compiler, and change compiler to XeLaTeX.

1
  • 7
    While using xetex may be a good idea it is not really a solution to the error here, the U+200E should probably not be in the source anyway, and to change from pdftex to xetex requires more changes than you suggest here, you typically need to change all the document font setup. Commented Jul 21, 2019 at 15:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .