I am having great difficulty to install the font MinionPro in TeX Live 2011.

I followed all the steps in the README file on CTAN, but I get the following error when compiling the text:

Process started: xelatex -interaction=nonstopmode "Teste8".tex

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 MinionPro-ItLCDFJ.pfb

mktexpk: don't know how to create bitmap font for MinionPro-ItLCDFJ.pfb. mktexpk: perhaps MinionPro-ItLCDFJ.pfb is missing from the map file.

kpathsea: Appending font creation commands to missfont.log. ** WARNING **
Could not locate a virtual/physical font for TFM "MinionPro-It--lcdfj". ** 
WARNING ** >> This font is mapped to a physical font "MinionPro-
ItLCDFJ.pfb". ** WARNING ** >> Please check if kpathsea library can find 
this font: MinionPro-ItLCDFJ.pfb ** ERROR ** Cannot proceed without .vf or
"physical" font for PDF output... Output file removed.

Process exited normally

.pfb files were generated and copied to the correct directory. Also all related files are already located at TeX Live as MinionPro.map, etc...

However, I noticed that files ending in LCDFJ can not be opened because they have 0 kb. It has something to do?

Note: The file compiles normally with pdfLaTeX. I can not compile when using LaTeX ... which may be the problem?

I need the file to be compiled with LaTeX, because I use a plugin that does not work with XeLaTeX, just with LaTeX.

  • What's the conflicting plugin/package? Does it work with LuaLaTeX?
    – Chel
    Mar 30, 2012 at 23:05

2 Answers 2


The problem is that MinionPro does something screwy with the dotlessj glyph. XeTeX chokes when it sees the weirdness, even though PDFTeX apparently ignored it. This was discussed before here, but there's no complete answer there. The salient points:

  1. If you must use the MinionPro package (or fontspec for text and MinionPro for math) then download the entire MinionPro sources and go through the procedure found here:

    ./scripts/makeall --nodotlessj
    ./scripts/generate-glyph-list.sh > scripts/glyph-list-2.030
    ./scripts/makeall --nodotlessj --pack="`pwd`/scripts/glyph-list.2.030"

    You may also have to look through MinionPro.map for some entry with a ?, but I never had to do that.

  2. For future reference, in case you ever want to use Minion Pro with XeTeX then it's easiest to use fontspec and mathspec to get Minion Pro working. You could load the font like this:

    \setmainfont[Numbers={Lining,Proportional}]{Minion Pro}
    \setmathsfont(Digits,Latin,Greek)[Numbers={Lining,Proportional}]{Minion Pro}

    If you need to use LuaTeX, you could approximate the same with unicode-math, like my answer here. But both of these solutions mess up spacing for math sequences like $(f)$.

  • Thanks for the reply. These commands must be run as root? The first and the last command worked. The second command returned an error message: user@xyz: ~/MinionPro/files/source$./scripts/generate-glyph-list.sh> scripts/glyph-list-2.030 cat: dvips/a_*.enc: File or directory not found
    – mneto
    Mar 30, 2012 at 23:56
  • I guess I was wrong. I downloaded the source directly from CTAN ... The link you gave me is more updated? How do I download the source files? Sorry, I can not use a lot of cvs.
    – mneto
    Mar 31, 2012 at 0:15
  • @mneto Just as it says, cvs -d:pserver:[email protected]:/cvsroot/minionpro login && cvs -z3 -d:pserver:[email protected]:/cvsroot/minionpro co MinionPro
    – Chel
    Mar 31, 2012 at 0:18
  • Thanks again. Everything worked normally. I ran the three commands above, and the install script, but when compiling the latex, I got the error: ** ERROR ** Unable to find TFM file "MinionPro-Regular-lf-t1 - base." Output file removed.
    – mneto
    Mar 31, 2012 at 1:00
  • During the installation attempts, I put many copies of the files in several locations in TeXLive. Could this be the problem? Also, I used a very new version of the font MinionPro distributed with a recent Acrobat Reader. The Files MinionPro*LCDFJ.pfb still have zero length. I will try an older version and redo all the previous steps.
    – mneto
    Mar 31, 2012 at 12:23

The problem of the dotless j might have something to do with a newer version of the LCDF typetools. Anyway, I modified the part of the MinionPro script, which now works well for me. FontPro can be found here. Furthermore, I fixed some little bugs and added a feature. Also supported now is MyriadPro (with a complete set of mathematical symbols called MdSymbol) and CronosPro.

For installation, follow the README. The procedure is almost identical to the one of the original MinionPro scripts except that you have to name which font you want to generate the support files for in step 3).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .