0

The problem

After updating MiKTeX (MiKTeX 2.9.7050 64-bit) and Texmaker (two clean re-installations after several issues I had with obsolete packages), my tex file wouldn't compile properly anymore, especially regarding my different levels of footnotes. Two errors emerged and my output would be fulled of added =.

I identified the problem as coming from the bigfoot package. I was previously using bigfoot in explicit combination with manyfoot and perpage and it was working fine. I soon discovered it was better to use bigfoot alone (as it relies on manyfoot and perpage anyway). But the errors occured in both case in the exact same way.

The two errors are the following and they emerge at each footnote:

! Missing number, treated as zero.
<to be read again> 
               =
l.12 \footnote{
           A numbered footnote.}
?
! Illegal unit of measure (pt inserted).
<to be read again> 
               =
l.12 \footnote{
           A numbered footnote.}
? 

The result being each footnote mark (in the text) to be followed by a = sign. Plus, another = sign is added at the begining of every page except the first one.

I checked online (notably on Overleaf) for what seems to be a very common error but no case instructed seems to be relevant to my problem. For the first error, I checked here, and here for the second one. The TeXfaq also mentionned a problem when upgrading from a LaTeX 2.9 but it was not the case here.

M(N)WE

Here is a MWE:

% xelatex
\listfiles
\documentclass[10pt,a4paper]{article}

\usepackage{bigfoot}
\DeclareNewFootnote[plain]{default}
\DeclareNewFootnote[plain]{B}[alph]
\DeclareNewFootnote[plain]{C}[fnsymbol]

\begin{document}

\footnote{A numbered footnote.}
\footnoteB{An alphabetical footnote.}
\footnoteC{A footnote with symbols.}

\clearpage

\footnote{A second numbered footnote.}

\end{document}

Logfile and filelist

The logfile:

This is XeTeX, Version 3.14159265-2.6-0.999991 (MiKTeX 2.9.7050 64-bit) (preloaded format=xelatex 2019.7.21)  26 JUL 2019 22:09
entering extended mode
**./mwe2.tex
(mwe2.tex
LaTeX2e <2018-12-01>
("C:\Program Files\MiKTeX 2.9\tex/latex/base\article.cls"
Document Class: article 2018/09/03 v1.4i Standard LaTeX document class
("C:\Program Files\MiKTeX 2.9\tex/latex/base\size10.clo"
File: size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option)
)
\c@part=\count80
\c@section=\count81
\c@subsection=\count82
\c@subsubsection=\count83
\c@paragraph=\count84
\c@subparagraph=\count85
\c@figure=\count86
\c@table=\count87
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
("C:\Program Files\MiKTeX 2.9\tex/latex/bigfoot\bigfoot.sty"
Package: bigfoot 2015/08/30 2.1 makes footnotes work
(C:\Users\Erizo\AppData\Roaming\MiKTeX\2.9\tex/latex/manyfoot\manyfoot.sty
Package: manyfoot 2005/09/11 v1.10 Many Footnote Levels Package (NCC)

(C:\Users\Erizo\AppData\Roaming\MiKTeX\2.9\tex/latex/nccfoots\nccfoots.sty
Package: nccfoots 2005/02/03 v1.2 NCC Footnotes Package (NCC)
)
\MFL@columnwidth=\dimen103
)
("C:\Program Files\MiKTeX 2.9\tex/latex/bigfoot\suffix.sty"
Package: suffix 2006/07/15 1.5a Variant command support
)
(C:\Users\Erizo\AppData\Roaming\MiKTeX\2.9\tex/latex/perpage\perpage.sty
Package: perpage 2006/07/15 1.12 Reset/sort counters per page
\c@abspage=\count88
)
\footnotewidowpenalty=\count89
\footnoteclubpenalty=\count90
\finalfootnotewidowpenalty=\count91
\c@FN@totalid=\count92
\c@pp@a@FN@totalid=\count93
\FN@id=\count94
\FN@master=\marks1
\FN@slave=\marks2
\FN@color=\marks3
\FN@outervsize=\dimen104
\FN@vsize=\skip43
\FN@insertions=\box27
\FN@output=\toks14
\FN@tempbox=\box28
\FN@savebox=\insert199
\FN@topmarkbox=\box29
\FN@outputflag=\count95
\FN@myvsize=\dimen105
\bigfoottolerance=\count96
)
\footinsdefault=\insert198
\c@footnotedefault=\count97
\footinsB=\insert197
\c@footnoteB=\count98
\footinsC=\insert196
\c@footnoteC=\count99

(mwe2.aux)
\openout1 = `mwe2.aux'.

LaTeX Font Info:    Checking defaults for OML/cmm/m/it on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for T1/cmr/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for OT1/cmr/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for OMS/cmsy/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for TU/lmr/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for OMX/cmex/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
LaTeX Font Info:    Checking defaults for U/cmr/m/n on input line 10.
LaTeX Font Info:    ... okay on input line 10.
\FN@cache198=\box30
\FN@cache197=\box31
\FN@cache196=\box32
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <7> on input line 12.
LaTeX Font Info:    External font `cmex10' loaded for size
(Font)              <5> on input line 12.
! Missing number, treated as zero.
<to be read again> 
                   =
l.12 \footnote{
               A numbered footnote.}
? 
! Illegal unit of measure (pt inserted).
<to be read again> 
                   =
l.12 \footnote{
               A numbered footnote.}
?

The filelist:

 *File List*
 article.cls    2018/09/03 v1.4i Standard LaTeX document class
  size10.clo    2018/09/03 v1.4i Standard LaTeX file (size option)
 bigfoot.sty    2015/08/30 2.1 makes footnotes work
manyfoot.sty    2005/09/11 v1.10 Many Footnote Levels Package (NCC)
nccfoots.sty    2005/02/03 v1.2 NCC Footnotes Package (NCC)
  suffix.sty    2006/07/15 1.5a Variant command support
 perpage.sty    2006/07/15 1.12 Reset/sort counters per page

Any idea of how I could solve that problem?

  • I don't seem to get any error with TeXLive 2019 using Kile. *File List* article.cls 2018/09/03 v1.4i Standard LaTeX document class size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option) bigfoot.sty 2015/08/30 2.1 makes footnotes work manyfoot.sty 2005/09/11 v1.10 Many Footnote Levels Package (NCC) nccfoots.sty 2005/02/03 v1.2 NCC Footnotes Package (NCC) suffix.sty 2006/07/15 1.5a Variant command support perpage.sty 2014/10/25 2.0 Reset/sort counters per page omscmr.fd 2014/09/29 v2.5h Standard LaTeX font definitions *********** – azetina Jul 26 at 21:12
  • 1
    you have very old files perpage should be 2014 for example I get this filelist *File List* article.cls 2018/09/03 v1.4i Standard LaTeX document class size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option) bigfoot.sty 2015/08/30 2.1 makes footnotes work manyfoot.sty 2005/09/11 v1.10 Many Footnote Levels Package (NCC) nccfoots.sty 2005/02/03 v1.2 NCC Footnotes Package (NCC) suffix.sty 2006/07/15 1.5a Variant command support perpage.sty 2014/10/25 2.0 Reset/sort counters per page *********** – David Carlisle Jul 26 at 21:14
  • 2
    note your packages come from two different trees, the old perpage one comes from your folder, so this is the standard miktex FAQ, you need to update both user and admin versions in the miktex console. – David Carlisle Jul 26 at 21:16
  • @DavidCarlisle your were right. The problem came from Texmaker calling old packages from the personnal MiKTeX tree. I will now pay very careful attention to that point when installing new pakages. Thanks a lot. – Mosley Jul 27 at 9:24
0

As David Carlisle mentionned it in a comment, the problem came from Texmaker calling and using old packages installed into the personnal user MiKTeX tree (C:\Users\<your_user_name>\AppData\Roaming\MiKTeX\2.9\...) and not the one installed into the admin MiKTeX tree (C:\Program Files\MiKTeX 2.9\...) as I expected. The later one being the one up-to-date.

In this specific case, related to using the bigfoot package, three sty files were called from the personnal user MiKTeX tree. The problem is that some old semi-independant packages (perpage and bigfoot for example) were also integrated into a renewed one since then (the new bigfoot) so the sty files are not disposed into the same files anymore. So the previous situation:

  • manyfoot.sty called from the independant package manyfoot in the personnal user MiKTeX tree. This file is now part of the ncctools bundle.
  • nccfoots.sty called from the independant package nccfoots in the personnal user MiKTeX tree. This file is now part of the ncctools bundle too.
  • perpage.sty called from the independant package perpage in the personnal user MiKTeX tree. This file is now part of the bigfoot package.

Solution

  • In the personal user MiKTeX tree, delete manually the files of the old versions of bigfoot, manyfoot, nccfoots and perpage (they all are in C:\Users\<your_user_name>\AppData\Roaming\MiKTeX\2.9\tex\latex\).
  • Open the MiKTeX (admin) console, (re)install the following packages: bigfoot and ncctools.
  • In the MiKTeX (admin) console, refresh the file name database (FNDB).
  • Now, open the MiKTeX (user) console and refresh its file name database (FNDB) too.

Your compilation should now run smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.