3

Opened MikTeX Console to perform an update to the installed modules, and an error occurred during the installation of one or more modules. This prompted the following message to keep appearing:

The code execution cannot proceed because MSVCP140_CODECVT_IDS.dll was not found. Reinstalling the program may fix this problem.

MikTeX Console cannot be opened without the error reappearing. Running the default uninstaller for MikTeX triggers the same error message (pointing to a corrupted MikTeX installation).

Any suggestions to solve this problem?

  • related : tex.stackexchange.com/questions/501786/… – AndréC Jul 28 '19 at 5:53
  • This bug is reported here: github.com/MiKTeX/miktex/issues/346 – AndréC Jul 28 '19 at 5:54
  • The MikTeX package database has been taken off-line temporarily to avoid spreading the broken update, see miktex.org/alert/update-problem-7147. Updates are therefore not possible at the moment. Updates will be re-enabled when the fixed version is available (hopefully soon, but there might be a delay until all mirrors catch up with the update). – moewe Jul 28 '19 at 8:37
  • The MikTeX developer explains where to get the necessary .dll in github.com/MiKTeX/miktex/issues/346. – moewe Jul 28 '19 at 10:38
  • I was able to get MikTeX working today (29/07/2019) by reinstalling MikTeX (after first deleting the program files) and running the normal package update procedure within the console. This suggests that the problematic update package has been fixed/removed. I did not require the DLL patch as listed below. – jofa Jul 29 '19 at 11:52
1

The developer outlined how to install the missing dll in the corresponding Github issue:

  • Download the latest Visual C++ redistributable package from here. (Depending on your processor, that is the file vc_redist.x64.exe (64 bit processor), vc_redist.arm64.exe (64 bit ARM processor) or vc_redist.x86.exe (32 bit processor).
  • Run initexmf --mklinks --verbose --force in the command line (cmd or PowerShell). You can open PowerShell by right-clicking on the Windows button and selecting "Windows PowerShell (Admin)".
| improve this answer | |
  • 1
    Have you tested this yourself? – AndréC Jul 28 '19 at 11:20
  • 1
    @AndréC I have not (I do not have the corrupted update, so I can't). It has been tested, though (according to Ulrike Fischer in the issue comments, which is good enough for me). – schtandard Jul 28 '19 at 11:43
  • Ulrike is a great professional, I'm not sure that an amateur can do it as well as she can... – AndréC Jul 28 '19 at 11:57
  • Tried to recreate the error today (29/07) while I was reinstalling MikTeX and it appears the problematic package has been fixed/removed in the updates. This patch may no longer be necessary. – jofa Jul 29 '19 at 11:53
  • 1
    The issue has been fixed. MikTeX has updated the miktex.org/packages/miktex-vc140-bin-x64 package that ships the necessary .dlls (you can verify that at miktex.org/Package/Browse/miktex-vc140-bin-x64). I didn't update my system yesterday due to the bug, but I did so just now: Everything is working as expected and without errors even though I did not download or install vc_redist.x64.exe from the MS site. – moewe Jul 29 '19 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.