0

After finishing my thesis in one sided book, I switched it to double sided and latex added extra pages such that chapters always start on even pages. See code below; However with contents for example, the first two pages show the correct header which is 'Contents' then the next and extra page which Latex adds shows the heading 'List of Figures' of the next chapter (see image below).

enter image description here

\addcontentsline{toc}{chapter}{Contents}
\lhead{\emph{Contents}}
\tableofcontents

% list of figures
\addcontentsline{toc}{chapter}{List of Figures}
\lhead{\emph{List of Figures}}
\listoffigures

% list of tables
\addcontentsline{toc}{chapter}{List of Tables}
\lhead{\emph{List of Tables}}
\listoftables

This is part of my preamble \documentclass[12pt,a4paper,twoside]{book} \usepackage{fancyhdr}

11
0

You need to use the openany option in your documentclass, e.g. \documentclass[12pt,a4paper,twoside,openany]{book} to prevent the insertion of extra pages.

Not the answer you're looking for? Browse other questions tagged or ask your own question.