1

I am trying to cite an article with two authors. The maximum amount of names to two:

\usepackage[backend=biber, style=authoryear, maxcitenames=2, sorting=nyt, maxbibnames =99, hyperref=true, uniquelist=false, datelabel=comp]{biblatex}

The reference is as:

@article{NUTS,
    title = "The No-U-Turn Sampler: Adaptively Setting Path Lengths in Hamiltonian Monte Carlo",
    author = "Hoffman, Matthew and Gelman, Andrew",
    year = "2014",
    volume = "15",
    journal = "Journal of Machine Learning Research"
}

I cite the article in text as follows:

Bla bla bla \cite{NUTS} bla bla.

Which gives me:

Bla bla bla Hoffman and Andrew Gelman 2014 bla bla.

How do you avoid the second authors name being cited in full? Desired output:

Bla bla bla Hoffman and Gelman 2014 bla bla.

marked as duplicate by moewe, Mensch, Sebastiano, Stefan Pinnow, Phelype Oleinik Jul 30 at 17:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    I can't say for sure without an MWE () that reproduces the undesirable output, but I would bet on the uniquename disambiguation feature. You probably have another work authored by another Gelman (it might indeed even be the same Gelman, just in a different form: Gelman, Andrew and Gelman, Andrew J. are two different names to biblatex even if they refer to the same person). Try uniquename=false, see also tex.stackexchange.com/q/134535/35864 – moewe Jul 29 at 16:22
  • For most intents and purposes the option hyperref=true, is no better than the default setting hyperref=auto,. The two option differ only in the behaviour when the package hyperref is not loaded: hyperref=true, will throw a warning, hyperref=auto will just silently accept that. In particular both settings produce links if and only if the hyperref package is loaded. In current versions of biblatex the option datelabel is deprecated, it has been replaced by labeldate. sorting=nyt is already the default if you load style=authoryear,. – moewe Jul 29 at 16:24
  • Sorry, forgot the link to the MWE meta page in my first comment: tex.meta.stackexchange.com/q/228/35864, tex.meta.stackexchange.com/q/4407/35864 – moewe Jul 29 at 16:42
  • @moewe, thanks for the answer. It was the uniquename option that did the trick. I have set the option to False as of now, but I should probably be more consistent in my bibliography. I will definitely check out the MWE, such that my questions are easier to answer in the future :) – user193615 Jul 30 at 8:55
  • Very good. Since uniquename=false, solved your problem I vote to close as a duplicate of the question I linked above. (It's an interesting question whether you should be consistent in the bibliography. On the one hand it is certainly nice to have a consistent bibliography where the same name always appears in the same form. On the other hand I can see why one would want to stick to the form in the source as closely as possible.) – moewe Jul 30 at 15:23

Browse other questions tagged or ask your own question.