2

I found a programme named mflua, that said:

$ mflua
MFLua version: 0.9.1
MFLua banner:  This is MFLua, Version 2.7182818-0.9.1
This is MFLua, Version 2.7182818-0.9.1 (TeX Live 2019) (preloaded base=mflua)
**

This gave me some hope it might work interactively with the X Window System, which mf does not, so I said

**\relax

But, to my disappontment, mflua replied:

kpathsea: Running mktexfmt mflua.base
mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order):
mktexfmt:   /opt/texlive/2019/texmf-dist/web2c/fmtutil.cnf
mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes:
mktexfmt:   /home/toothrot/.texlive2019/texmf-config/web2c/fmtutil.cnf
mktexfmt [INFO]: writing formats under /home/toothrot/.texlive2019/texmf-var/web2c
mktexfmt [INFO]: did not find entry for byfmt=mflua, skipped
mktexfmt [INFO]: Disabled formats: 6
mktexfmt [INFO]: Not selected formats: 39
mktexfmt [INFO]: Total formats: 45
mktexfmt [INFO]: exiting with status 0
I can't find the base file `mflua.base'!

Was there anything I could have said or done that would have produced a less disappointing output? I mean, I expected this programme to work more or less like mf, giving me a * prompt after \relax, but apparently something is missing.

I also tried specifying mf as the base, but that didn't help:

**&mf

kpathsea: Running mktexfmt mf.base
mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order):
mktexfmt:   /opt/texlive/2019/texmf-dist/web2c/fmtutil.cnf
mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes:
mktexfmt:   /home/toothrot/.texlive2019/texmf-config/web2c/fmtutil.cnf
mktexfmt [INFO]: writing formats under /home/toothrot/.texlive2019/texmf-var/web2c
mktexfmt [INFO]: --- remaking mf with mf-nowin
mktexfmt: running `mf-nowin -ini   -jobname=mf -progname=mf -translate-file=cp227.tcx mf.ini' ...
This is METAFONT, Version 2.7182818 (TeX Live 2019) (INIMF)
(/opt/texlive/2019/texmf-dist/web2c/cp227.tcx)
(/opt/texlive/2019/texmf-dist/metafont/config/mf.ini
(/opt/texlive/2019/texmf-dist/metafont/base/plain.mf
Preloading the plain base, version 2.71: preliminaries,
basic constants and mathematical macros,
macros for converting from device-independent units to pixels,
macros and tables for various modes of operation,
macros for drawing and filling,
macros for proof labels and rules,
macros for character and font administration,
and a few last-minute items.)
(/opt/texlive/2019/texmf-dist/metafont/misc/modes.mf) )
Beginning to dump on file mf.base
(preloaded base=mf 2019.7.29)
2226 strings of total length 30019
11855 memory locations dumped; current usage is 3651&7844
1004 symbolic tokens
Transcript written on mf.log.
mktexfmt [INFO]: /home/toothrot/.texlive2019/texmf-var/web2c/metafont/mf.base installed.
mktexfmt [INFO]: Disabled formats: 6
mktexfmt [INFO]: Successfully rebuilt formats: 1
mktexfmt [INFO]: Not selected formats: 38
mktexfmt [INFO]: Total formats: 45
mktexfmt [INFO]: exiting with status 0
---! /home/toothrot/.texlive2019/texmf-var/web2c/metafont/mf.base was written by metafont
(Fatal base file error; I'm stymied)
  • Can you open a command window and type mflua --help? – Mico Jul 29 '19 at 20:10
  • @Mico, yes, but that's not very enlightening. – Toothrot Jul 29 '19 at 20:17
  • I found an entry in fmtutil.cnf mflua mflua-nowin - mf.ini. You could add it to a local fmtutil.cnf and try again (it doesn't work for me, but I'm on windows.) – Ulrike Fischer Jul 29 '19 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.