1

This problem seems to specific to printing the output of OverLeaf. At the printing stage the PDF file seems to shrink. The issue is not observed on, say, TeXStudio.

I tex the document on overleaf, using pdflatex as the engine, and I print the output pdf file. While on screen the file looks ok, during the printing the page view of the output as well as the actual printed text seem to shrink by about 25%, with extra wide margins appearing on right and bottom.

Here are some variations I tried

\documentclass{article}
\usepackage{lipsum}


%Use either
\usepackage{geometry}
\geometry{lmargin=0.5in,bmargin=0.5in,tmargin=0.5in,rmargin=0.5in}

%or
%\usepackage[letterpaper,left=.2in,right=0.2cm,top=0.5cm,bottom=0.5cm]{geometry}

\begin{document}
\lipsum
\end{document}

The display looks OK but when I display the page to be printed it has extra margin on right and bottom. As if the output shrank.

This is output

This is how the printer setting looks like

enter image description here

  • With your MWE I cant reproduce your problem. All margins are equal to 0.5 in. BTW, instead lmargin=0.5in,bmargin=0.5in,tmargin=0.5in,rmargin=0.5in you can shortly write: margin=0.5in. to see your page layout, you can add to geometry settings showframe option. – Zarko Aug 2 at 21:02
  • @Zarko For me when the PDF is displayed on screen the margin sizes look right, but when it is printed the text appears as in the image above with extra white space on right. Also with Showframe the margins appear correct, with no extra wide space on right. – Maesumi Aug 2 at 21:13
  • Then you have problem with printer settings. – Zarko Aug 2 at 21:23
  • @Zarko Yes, I began to suspect my printer setting. But printer's test paper comes out without any margin issue. It is set to "letter". – Maesumi Aug 2 at 21:42
  • 1
    your problem is well elaborated in @Mensch answer. – Zarko Aug 2 at 21:50
2

Well, I have a current MiKTeX installation for standard A4paper.

If I compile your given code (added option showframe to visualize the typing area and margins) I get the following two results:

MWE 1:

\documentclass{article}

\usepackage{lipsum}

%Use either
%\usepackage[showframe]{geometry} % <===================================
%\geometry{lmargin=0.5in,bmargin=0.5in,tmargin=0.5in,rmargin=0.5in}

%or
\usepackage[%
  showframe, % <========================================================
  letterpaper,left=.2in,right=0.2cm,top=0.5cm,bottom=0.5cm
]{geometry}

\begin{document}
\lipsum
\end{document} 

and the result viewed with SumatraPDF:

result with letterpager

MWE 2:

\documentclass{article}

\usepackage{lipsum}

%Use either
\usepackage[showframe]{geometry} % <===================================
\geometry{lmargin=0.5in,bmargin=0.5in,tmargin=0.5in,rmargin=0.5in}

%or
%\usepackage[%
  %showframe, % <========================================================
  %letterpaper,left=.2in,right=0.2cm,top=0.5cm,bottom=0.5cm
%]{geometry}

\begin{document}
\lipsum
\end{document}

and the resulting pdf with meta infos:

result 2

and if I explizit want to get a4paper:

\documentclass[a4paper]{article} % <====================================
%\documentclass{article}

\usepackage{lipsum}

%Use either
\usepackage[showframe]{geometry} % <===================================
\geometry{lmargin=0.5in,bmargin=0.5in,tmargin=0.5in,rmargin=0.5in}

%or
%\usepackage[%
  %showframe, % <========================================================
  %letterpaper,left=.2in,right=0.2cm,top=0.5cm,bottom=0.5cm
%]{geometry}

\begin{document}
\lipsum
\end{document}

and the result in pdf viewer:

result a4

Now it depends on your used printer: is it a letterpaper or a4paper printer? Can you show its configuration in your question please?

BTW: If I print the a4 variant on my a4 printer everything is as it should be ...

Okay, just a wild guess:

In my printer I can change the size for the to be printed document for example to 78 % like here (sorry menu is in German):

printing menu

As you can see marked with the both red arrows on the left the printing size is definded to be 78 % and the result you see on the right marked with the arrows with the flash: The right margin gots too wide ...

  • thanks, I experimented with that. I still get same wide right margins even though I use 100% magnification and "letterpaper" setting with the printer set on "letter". I am experimenting by setting printer on 125% and it seems to work! Not sure. – Maesumi Aug 2 at 21:59
  • @Maesumi try to show the relevant printer configuration in one or more screenshots in your question ... Without seeing that configuration I and all the others here can only guess as I already did ... – Mensch Aug 2 at 22:09
  • I added a snap shot of printer setting. – Maesumi Aug 5 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.