1

I'm trying to change the following delimiters from periods into commas:

Delimiters I'm looking to change

Tex File:

\documentclass[paper=A4,12pt]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{setspace}
\usepackage{lmodern}
\usepackage[left=25mm, right=50mm, top=25mm, bottom=20mm]{geometry}
\setlength{\parindent}{0pt}
\onehalfspacing

\usepackage[
    backend=biber,
    style=ext-verbose-inote,
    autocite=footnote,
    sortlocale=de_DE,
    innamebeforetitle=true,
    natbib=true,
    url=false,
    doi=true,
    eprint=false
]{biblatex}
\addbibresource{literatur.bib}


\DeclareFieldFormat[incollection]{title}{#1}
\DeclareFieldFormat[incollection]{booktitle}{#1}

\renewcommand{\multinamedelim}[0]{ / }
\renewcommand{\finalnamedelim}[0]{ / }

\DeclareNameAlias{sortname}{last-first}
\DeclareNameAlias{default}{last-first}


%\usepackage{xpatch}
%\def\dopatchbibdrivereditorcomma#1{%
%  \xpatchbibdriver{#1}
%    {\usebibmacro{maintitle+booktitle}%
%     \newunit\newblock}
%    {\usebibmacro{maintitle+booktitle}%
%     \setunit{\addcomma\space}\newblock}
%    {}
%    {\typeout{failed to patch driver for type #1}}}
%\forcsvlist{\dopatchbibdrivereditorcomma}{inbook,incollection,inproceedings}



\begin{document}

\begin{titlepage}
\begin{spacing}{1}
   Some Text
  \end{spacing}
\end{titlepage}

\newpage
\tableofcontents
\addtocontents{toc}{\protect\thispagestyle{empty}}
\newpage
\setcounter{page}{1}
\section{Erster Abschnitt}
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua\Footcite[Vgl.][]{dbwnf}. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua\Footcite[Vgl.][]{dbwnf}. .. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.
\printbibliography[keyword=pl, title={Primärliteratur}]
\end{document}

bib file:

@book{test,
    Author = {Test},
    Booktitle = {test},
    Date-Added = {2019-08-04 15:48:27 +0200},
    Date-Modified = {2019-08-04 15:48:37 +0200},
    Publisher = {test},
    Title = {test},
    Year = {2019}}

@incollection{dbwnf,
    Address = {M{\"u}nchen},
    Author = {Dietrich Bonhoeffer},
    Booktitle = {Dietrich Bonnhoeffer Werke},
    Date-Added = {2019-08-04 14:01:21 +0200},
    Date-Modified = {2019-08-04 14:54:00 +0200},
    Editor = {Kuske, Martin and T{\"o}dt, Ilse},
    Keywords = {pl},
    Title = {Nachfolge},
    Year = {1989}}

I've checked the biblatex-ext documentation but have not been able to identify the relevant delimiters and how to change them.

3
  • 2
    Would it be possible to post a small example document that reproduces the output you show in the picture with as little code as possible (a so-called MWE: tex.meta.stackexchange.com/q/228/35864 or MWEB: tex.meta.stackexchange.com/q/4407/35864). We need to know which bibliography/citation style you use and which settings you apply. Do you want to change this only in citations (footnote citations) or also in the bibliography? – moewe Aug 4 '19 at 13:38
  • Should be changed in both. I'm using the following options: \usepackage[ backend=biber, style=ext-verbose-inote, autocite=footnote, sortlocale=de_DE, innamebeforetitle=true, natbib=true, url=false, doi=true, eprint=false ]{biblatex} \addbibresource{literatur.bib} – Lucas Aug 4 '19 at 13:39
  • OK. Please note that you can (and should!) edit your question (information in the comments might be overlooked and the question should be self-contained). Also note that the \usepackage line is not a full example document in the sense of an MWE (see links above): An MWE should be a fully compilable document with \documentclass, the necessary preamble code and a \begin{document}...\end{document} with as much dummy contents as necessary to reproduce the issue. – moewe Aug 4 '19 at 13:53
1

The delimiter between author (or editor) name and title is called nametitledelim. It can be changed with

\DeclareDelimFormat[bib]{nametitledelim}{\addcomma\space}

The delimiter before the location does not have a special name. biblatex just prints the usual \newunitpunct there. We could modify ext-standard's pubinstorg+location+date macro here to print a comma before the location

\renewbibmacro*{pubinstorg+location+date}[1]{%
  \setunit{\addcomma\space}%
  \printlist{location}%
  \iflistundef{#1}
    {\setunit*{\locdatedelim}}
    {\setunit*{\locpubdelim}}%
  \printlist{#1}%
  \setunit*{\pubdatedelim}%
  \usebibmacro{date}%
  \newunit}

It appears to me, however, that you want a comma in almost all places, except before the "in:", so maybe the following idea, where \newunitpunct is set to a comma and we only add a period before the "in:", works better for you.

\documentclass[paper=A4,12pt]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage{lmodern}

\usepackage[
  backend=biber,
  style=ext-verbose-inote,
  autocite=footnote,
  innamebeforetitle=true,
  natbib=true,
  url=false,
  doi=true,
  eprint=false
]{biblatex}

\renewcommand*{\newunitpunct}{\addcomma\space}

\renewbibmacro*{in:}{%
  \setunit{\addperiod\space}%
  \printtext{%
    \bibstring{in}\intitlepunct}}

\DeclareNameAlias{default}{family-given}
\DeclareNameAlias{sortname}{default}

\DeclareDelimFormat{multinamedelim}{\addspace\slash\space}
\DeclareDelimAlias{finalnamedelim}{multinamedelim}


\DeclareFieldFormat[incollection]{title}{#1}
\DeclareFieldFormat[incollection]{booktitle}{#1}


\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{test,
  Author    = {Test},
  Booktitle = {test},
  Publisher = {test},
  Title     = {test},
  Year      = {2019},
}
@incollection{dbwnf,
  Address   = {München},
  Author    = {Dietrich Bonhoeffer},
  Booktitle = {Dietrich Bonnhoeffer Werke},
  Editor    = {Kuske, Martin and Tödt, Ilse},
  Keywords  = {pl},
  Title     = {Nachfolge},
  Year      = {1989},
}
\end{filecontents}

\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}


\begin{document}
Lorem\Footcite[Vgl.][]{dbwnf}.
Ipsum\Footcite[Vgl.][]{test}.

\printbibliography[keyword=pl, title={Primärliteratur}]
\end{document}

Vgl. Bonhoeffer, Dietrich, Nachfolge. In: Kuske, Martin / Tödt, Ilse, Hrsg., Dietrich Bonnhoeffer Werke, München, 1989.//Vgl. Test, test, test, 2019.


In any case you may want to have a look at the slight modernisations to your code that I applied in the MWE above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.