1

Bonjour, I try to compile a file containing pstricks figures with xelatex myfile.tex and I got this message:

This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/Debian) (preloaded format=xelatex)
 restricted \write18 enabled.

kpathsea: Running mktexfmt xelatex.fmt
mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order):
mktexfmt:   /usr/share/texmf/web2c/fmtutil.cnf
mktexfmt:   /usr/share/texlive/texmf-dist/web2c/fmtutil.cnf
mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes:
mktexfmt:   /home/jacob/.texlive2017/texmf-config/web2c/fmtutil.cnf
mktexfmt [INFO]: writing formats under /home/jacob/.texlive2017/texmf-var/web2c
mktexfmt [INFO]: --- remaking xelatex with xetex
mktexfmt: running `xetex -ini   -jobname=xelatex -progname=xelatex -etex xelatex.ini' ...
This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/Debian) (INITEX)
 restricted \write18 enabled.
entering extended mode
(/usr/share/texmf/tex/latex/latex_Tosh/latexconfig/xelatex.ini
! I can't find file `unicode-letters'.
l.6 \input unicode-letters

(Press Enter to retry, or Control-D to exit)
Please type another input file name: 
! Emergency stop.
l.6 \input unicode-letters

No pages of output.
Transcript written on xelatex.log.
mktexfmt [ERROR]: running `xetex -ini   -jobname=xelatex -progname=xelatex -etex xelatex.ini >&2 </dev/null' return status 1
mktexfmt [ERROR]: return error due to options --strict
mktexfmt [INFO]: Disabled formats: 3
mktexfmt [INFO]: Not selected formats: 42
mktexfmt [INFO]: Failed to build: 1 (xetex/xelatex)
mktexfmt [INFO]: Total formats: 46
mktexfmt [INFO]: exiting with status 1
I can't find the format file `xelatex.fmt'!

A previously put the xetex-pstricks package in my texmf tree hoping to solve the problem. Can somebody help? Thanks.

@raaja the link https://arxiv.org/abs/1006.3153 is functional. You really want me to copy the article.tex? @Ulrike Without the xetex.ini the log file is now: This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/Debian) (preloaded format=xelatex) restricted \write18 enabled.

kpathsea: Running mktexfmt xelatex.fmt mktexfmt: mktexfmt is using the following fmtutil.cnf files (in precedence order): mktexfmt: /usr/share/texmf/web2c/fmtutil.cnf mktexfmt: /usr/share/texlive/texmf-dist/web2c/fmtutil.cnf mktexfmt: mktexfmt is using the following fmtutil.cnf file for writing changes: mktexfmt: /home/jacob/.texlive2017/texmf-config/web2c/fmtutil.cnf mktexfmt [INFO]: writing formats under /home/jacob/.texlive2017/texmf-var/web2c mktexfmt [INFO]: --- remaking xelatex with xetex mktexfmt: running `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini' ... This is XeTeX, Version 3.14159265-2.6-0.99998 (TeX Live 2017/Debian) (INITEX) restricted \write18 enabled. entering extended mode (/usr/share/texlive/texmf-dist/tex/generic/tex-ini-files/xelatex.ini (/usr/share/texmf/tex/latex/latex_Tosh/base/latex.ltx (/usr/share/texmf/tex/latex/latex_Tosh/base/texsys.cfg) ./texsys.aux found

@currdir set to: ./.

Assuming \openin and \input have the same search path.

Defining UNIX/DOS style filename parser.

catcodes, registers, compatibility for TeX 2, parameters, LaTeX2e <2009/09/24>

hacks, control, par, spacing, files, font encodings, lengths,

Local config file fonttext.cfg used

==================================== (/usr/share/texmf/tex/latex/latex_Tosh/base/fonttext.cfg (/usr/share/texmf/tex/latex/latex_Tosh/base/fonttext.ltx === Don't modify this file, use a .cfg file instead ===

(/usr/share/texmf/tex/latex/latex_Tosh/base/omlenc.def) (/usr/share/texmf/tex/latex/latex_Tosh/base/t1enc.def) (/usr/share/texmf/tex/latex/latex_Tosh/base/ot1enc.def) (/usr/share/texmf/tex/latex/latex_Tosh/base/omsenc.def) (/usr/share/texmf/tex/latex/latex_Tosh/base/t1cmr.fd) (/usr/share/texmf/tex/latex/latex_Tosh/base/ot1cmr.fd) (/usr/share/texmf/tex/latex/latex_Tosh/base/ot1cmss.fd)

(/usr/share/texmf/tex/latex/latex_Tosh/base/ot1cmtt.fd)))

Local config file fontmath.cfg used Thanks for your help.

  • Could you add an MWE? welcome to TEXSE. – Raaja Aug 4 at 13:48
  • 1
    You seem to have a local xelatex.ini file: Try what happens if you remove it (/usr/share/texmf/tex/latex/latex_Tosh/latexconfig/xelatex.ini). – Ulrike Fischer Aug 4 at 13:49
  • @Raaja You mean the file I compiled? In fact I picked up a file on arxiv with pstricks code to test my installation:arxiv.org/format/1006.3153 – user282525 Aug 5 at 8:22
  • @user282525 please add the scripts here, links tend to die over time. – Raaja Aug 5 at 8:24
  • 1) I have edited my first post. Is that the right way to proceed on this forum? – user282525 Aug 5 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.