3

I'm getting the error "Command txs:///view-pdf-external not defined" when I click on the external viewer. Any help please?

1
  • Welcome to TeX SX! You have to define your external viewer in the menu Opttrions-> Configure TeX Studio -> Compilations.
    – Bernard
    Aug 12, 2019 at 20:54

1 Answer 1

5

Assuming the underlying OS is Windows:

  1. Download and install SumatraPDF from https://www.sumatrapdfreader.org/download-free-pdf-viewer.html (last accessed 2019-08-12-2255UTC+2)

  2. Open TeXstudio and go to Options -> Configure TeXstudio -> Commands -> External PDF viewer and add the following: "C:/Program Files/SumatraPDF/SumatraPDF.exe" %.pdf (default path to SumatraPDF, if default install path hasn't been changed during installation process.)

  3. Restart TeXstudio, compile .tex file, open PDF in external viewer.

1
  • It worked for me
    – learner
    Sep 13, 2023 at 3:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .