0

I had previously been working in Overleaf and due to slow compile times I decided to download my project and use MiKTeX. However small caps no longer works now that I'm working locally (using \textsc{}). I'm using the ebgaramond package for my font. From the console I get a number of warnings such as:

Package fontspec Warning: OpenType feature 'Numbers=Lowercase' (onum) not available for font 'EBGaramond-BoldItalic' with script 'CustomDefault' and language 'Default'.

I'm using LuaLaTex.

It's my understanding that Overleaf uses TeX Live. Does this have something to do with different package versions between Tex Live and MiKTeX?

\documentclass[12pt,postvopaper,openany,final]{memoir}
\usepackage[USenglish]{babel} %good idea to use just in case
\usepackage{fontspec}%for lualatex
\usepackage{ebgaramond} %for loading eb garamond
\usepackage{microtype} %fixes most spacing and box issues

\setlength{\parskip}{0pt plus 0pt minus 0pt} %use always to avoid latex messing with paragraph spacing

\setlrmarginsandblock{0.75in}{0.5in}{*}
\setulmarginsandblock{1in}{0.75in}{*}

\setheadfoot{0.1in}{0in}
\setheaderspaces{0.5in}{*}{*}

\linespread{1.1} %modifies the line spacing

\makepagestyle{normal}
    \makeevenhead{normal}{}{\textsc{author}}{\thepage}
    \makeoddhead{normal}{}{\textsc{title}}{\thepage}

\pagestyle{normal}
\emergencystretch=0.75em %use to fix overfull paragraphs, see badness output
\checkandfixthelayout

\begin{document}
\frontmatter
\mainmatter

Some sample text and \textsc{this should be small caps} but it isn't. The header should also be small caps but it isn't.

\backmatter
\end{document}

closed as off-topic by Marcel Krüger, Phelype Oleinik, Mensch, siracusa, Stefan Pinnow Aug 14 at 4:19

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Welcome to TeX.SE. Packages version can be different because they are maintained differently. However, this should not have any influence to the so basic command as \textsc{}.You may not have installed all fonts available on Overleaf so it can happen, that your fonts not support small caps. For some more concrete help, please provide small, self contained document, which we can test as it is and which reproduce your problem(s). – Zarko Aug 13 at 2:46
  • Thanks, I have edited my question with a sample of the code that isn't working. After reading about the fontspec package more and looking at the errors it seems like fontspec isn't recognizing some parts of the ebgaramond package for some reason, even though they worked fine on Overleaf. In addition to small caps not working it also no longer uses the "Old Style" numbers that were working fine in Overleaf. – ryooan Aug 13 at 3:02
  • In my MikTeX (recent version) it works as expected. Try to update your MikTeX installation. – Zarko Aug 13 at 3:09
  • 3
    I made a bug report about this, check the MiKTeX issue tracker. It's a luatex bug, texlive should be fine, its luatex version is different. – Ulrike Fischer Aug 13 at 5:41
  • 4
    I'm voting to close this question as off-topic because it is a known bug in MiKTeX's LuaTeX version. – Marcel Krüger Aug 13 at 22:59

Browse other questions tagged or ask your own question.