0
\documentclass[twocolumn]{aastex61}
\pdfoutput=1 %for arXiv submission
\usepackage{amsmath,amstext}
\usepackage[T1]{fontenc}
\usepackage{apjfonts} 
\usepackage[figure,figure*]{hypcap}

\renewcommand*{\sectionautorefname}{Section} %for \autoref
\renewcommand*{\subsectionautorefname}{Section} %for \autoref

\shorttitle{AASTeX 6.1 Template}
\shortauthors{AUthor A. et al.}

\begin{document}

\title{Title of the Paper}

\author{Author 1}
\author{Author 2}
\author{Author 3}

\affiliation{The UX}

\begin{abstract}
Abstract of this paper!
\end{abstract}
\keywords{keyword1 --- keyword2 --- keyword3}

\section{Introduction}
Intro to the paper

\section{Summary}
Summary text.

\acknowledgments
Acknowledgments.

%\facility{facility ID}
\facilities{facility ID, facility ID, facility ID} 
\software{Numpy}

\bibliographystyle{yahapj}
\bibliography{references}

\appendix
\section{appendix section}

\end{document}

After I use this command, in the preview section, I see my title and my abstract; but my introduction starts from a completely new page. How do I prevent this?

Here's the output:

page_1 page_2 page_3

P.S. I'm doing all of this in overleaf

2
  • Welcome to TeX.SE! Please add some more text to your question. What exactly is your problem? Just the code is not really clear. Also, an image of the output in question may be helpful.
    – schtandard
    Commented Aug 13, 2019 at 5:36
  • I'm so sorry, LOL. After I posted my question, for some reason, some of the details went missing (I suspect it was because I created an account and it didn't autosave). Let me redit Commented Aug 13, 2019 at 5:42

2 Answers 2

3

The aastex61 class defines \section to do

\def\section{%
\if@firstsection
      \maketitle
\global\@firstsectionfalse
     \setcounter{footnote}{\thefront@matter@foot@note}%
     \let\footnotetext=\old@foot@note@text
     \let\footnotemark=\old@foot@note@mark
   \clearpage
   \if@two@col
   \twocolumngrid
   \fi
\fi
    \@startsection{section}{1}{\z@}{9pt plus 1pt minus
    1pt}{4pt}{\apjsecfont\center}} 

The \if@firstsection conditional is set to true at the beginning, so the effect of the first \section command is to issue \maketitle:

\def\frontmatter@maketitle{%
\@author@finish
\if@firstsection
  \title@column\titleblock@produce
\onecolumngrid
\else
%
\global\firstaffiltrue
 \title@column\secondtitleblock@produce
\fi
  \suppressfloats[t]%
%% Prevent these from being turned off so that
%% we can use \maketitle again for \AllAuthors.
%%
%  \let\and\relax
  \let\affiliation\@gobble
  \let\author\@gobble
%  \let\@AAC@list\@empty
%  \let\@AFF@list\@empty
%  \let\@AFG@list\@empty
%  \let\@AF@join\@AF@join@error
%  \let\email\@gobble
%  \let\@address\@empty
% \let\maketitle\relax
%  \let\thanks\@gobble
\if@firstsection
  \let\abstract\@undefined\let\endabstract\@undefined
  \titlepage@sw{%
   \vfil
   \clearpage
  }{}%
\fi
}%

\let\maketitle\frontmatter@maketitle

The conclusion is that the page break after the abstract (actually, after all the front matter information) has been typeset is wanted.

You can remove the page break by adding, before \begin{document},

\makeatletter
\@booleanfalse\titlepage@sw
\makeatother

This no longer happens with aastex63 (which is also on TeX Live).

\documentclass[twocolumn]{aastex63}
\pdfoutput=1 %for arXiv submission
\usepackage{amsmath,amstext}
\usepackage[T1]{fontenc}
%\usepackage{apjfonts} 
\usepackage[figure,figure*]{hypcap}

\renewcommand*{\sectionautorefname}{Section} %for \autoref
\renewcommand*{\subsectionautorefname}{Section} %for \autoref

\shorttitle{AASTeX 6.1 Template}
\shortauthors{AUthor A. et al.}

\begin{document}

\title{Title of the Paper}

\author{Author 1}
\author{Author 2}
\author{Author 3}

\affiliation{The UX}

\begin{abstract}
Abstract of this paper!
\end{abstract}
\keywords{keyword1 --- keyword2 --- keyword3}

\section{Introduction}
Intro to the paper

\section{Summary}
Summary text.

\acknowledgments
Acknowledgments.

%\facility{facility ID}
\facilities{facility ID, facility ID, facility ID} 
\software{Numpy}

\bibliographystyle{yahapj}
\bibliography{references}

\appendix
\section{appendix section}

\end{document}

(I commented out apjfonts that I don't have)

enter image description here

0

Have you try this : https://stackoverflow.com/questions/55552325/unwanted-page-break-after-maketitle ? I think it could work in your particular case.

1
  • I don't know why this was downvoted, i guess { \let\clearpage\relax } after \end{abstract} is a valid option.
    – Sango
    Commented Aug 13, 2019 at 9:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .