0

I'm using TexMaker, but it doesn't read my .bib file.

Here is a sample .tex file:

\documentclass{article}

\begin{document}

Hello. \cite{nobody99}

\bibliographystyle{plain}
\bibliography{sources}

\end{document}

And here is my sources.bib file:

@article{nobody99,
author = {nobody},
title = {ciao},
year = {1999}
}

I'm using this compilation sequence : PdfLaTex + Bib(la)tex + PdfLaTex (x2) + ViewPDF

I have tried in many ways to make it work, but it doesn't. The log file appears like this:

LOG FILE : This is pdfTeX, Version 3.14159265-2.6-1.40.20 (MiKTeX 2.9.7140 64-bit) (preloaded format=pdflatex 2019.8.8) 13 AUG 2019 17:42 entering extended mode **./ciao.tex (ciao.tex LaTeX2e <2018-12-01> ("C:\Users\Admin\AppData\Local\Programs\MiKTeX 2.9\tex/latex/base\article.cls" Document Class: article 2018/09/03 v1.4i Standard LaTeX document class ("C:\Users\Admin\AppData\Local\Programs\MiKTeX 2.9\tex/latex/base\size10.clo" File: size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option) ) \c@part=\count80 \c@section=\count81 \c@subsection=\count82 \c@subsubsection=\count83 \c@paragraph=\count84 \c@subparagraph=\count85 \c@figure=\count86 \c@table=\count87 \abovecaptionskip=\skip41 \belowcaptionskip=\skip42 \bibindent=\dimen102 ) (C:\Users\Admin\Documents\test\build\ciao.aux) \openout1 = ciao.aux'. LaTeX Font Info: Checking defaults for OML/cmm/m/it on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Font Info: Checking defaults for T1/cmr/m/n on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Font Info: Checking defaults for OT1/cmr/m/n on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Font Info: Checking defaults for OMS/cmsy/m/n on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Font Info: Checking defaults for OMX/cmex/m/n on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Font Info: Checking defaults for U/cmr/m/n on input line 4. LaTeX Font Info: ... okay on input line 4. LaTeX Warning: Citationnobody99' on page 1 undefined on input line 6. No file ciao.bbl. [1 {C:/Users/Admin/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}] (C:\Users\Admin\Documents\test\build\ciao.aux) LaTeX Warning: There were undefined references. ) Here is how much of TeX's memory you used: 207 strings out of 492895 2487 string characters out of 3123736 59667 words of memory out of 3000000 4206 multiletter control sequences out of 15000+200000 3948 words of font info for 15 fonts, out of 3000000 for 9000 1141 hyphenation exceptions out of 8191 23i,4n,22p,114b,107s stack positions out of 5000i,500n,10000p,200000b,50000s Output written on C:\Users\Admin\Documents\test\build\ciao.pdf (1 page, 21001 b ytes). PDF statistics: 14 PDF objects out of 1000 (max. 8388607) 0 named destinations out of 1000 (max. 500000) 1 words of extra memory for PDF output out of 10000 (max. 10000000)

What am i doing wrong? Can anybody help me?

  • 1
    Welcome to TeX SX! What does the .blg file say? What exactly do maean with ‘does not work’? – Bernard Aug 13 at 15:55
  • Yes, sorry, "does not work" in this case means that the reference appear as [?] in the pdf and that I get a "citation nobody99 on page 1 undefined" in the message log. There is no .blg file – matteeeo Aug 13 at 15:59
  • Is the bibliography present, yet? – Bernard Aug 13 at 16:00
  • 2
    the log shows you ran pdflatex, but have you run bibtex? – David Carlisle Aug 13 at 16:08
  • The .bib file is in the same folder as the .tex file. I tried to compile manually with pdflatex bibtex pdflatex pdflatex, but nothing. I also tried to compile the .bib file alone using bibtex. – matteeeo Aug 13 at 16:13
0

Solved the problem: I had the option for using a "build" subdirectory for output files active. Once switched it off, the compilation went smoothly and the references were there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.