2

I am not an expert on Unix based systems.

I installed TexLive 2019 on my mac (Mojave 10.14.6) and in the end it advises me to:

Add /usr/local/texlive/2019/texmf-dist/doc/man to MANPATH.

Add /usr/local/texlive/2019/texmf-dist/doc/info to INFOPATH.

Most importantly, add /usr/local/texlive/2019/bin/x86_64-darwin to your PATH for current and future sessions.

The 2018 version had a graphical interface which was easier to handle.

Does anyone know what exactly should I do?

3
  • Welcome to TeX.SE.
    – Mico
    Commented Aug 16, 2019 at 1:37
  • 1
    If you use the MacTeX installer, all of this is done for you.
    – Alan Munn
    Commented Aug 16, 2019 at 3:33
  • The thing is that full MacTeX is huge. I actually installed the lighter version through this answer. I do recommend it for anyone. I followed the steps there and I got it working fine. Also it only stores approximately 500MB. I will leave the question here for future reference.
    – rvimieiro
    Commented Aug 16, 2019 at 12:49

1 Answer 1

2

By following this guide, I think I've managed to solve the issue. I work with 10.11.6 El Capitan. Let me resume: first and most important, I've added the third string to the PATH variable by typing in a terminal

sudo nano /etc/paths

then added the string /usr/local/texlive/2019/bin/x86_64-darwinlegacy as last line

terminal screenshot

press CTRL + X to close and press Y to save changes. If you close and re-open the terminal window and type echo $PATH you should see the new path added to the environment variable.

Similarly for the other two. Always in the terminal type

sudo nano /etc/manpaths

add the /usr/local/texlive/2019/texmf-dist/doc/man string, exit and save. For the last one I have some doubts on the effectiveness, since my file was initially void. Anyway, as usual, type in the terminal

sudo nano /etc/infopaths

and add /usr/local/texlive/2019/texmf-dist/doc/info

Finally, check that Tex Live Utility is reading the correct path (2019). Open that app, go to the preferences and point to the path of the 2019 version /usr/local/texlive/2019/bin/x86_64-darwinlegacy

Tex Live Utility preferences panel

Now Tex Live Utility should update the packages.

2
  • I think this is related to this answer on Linux, right?
    – rvimieiro
    Commented Sep 19, 2019 at 10:24
  • I don't know, because I just followed the instructions on the linked article and applied them to our case. Did you try my solution?
    – Danilo
    Commented Sep 21, 2019 at 17:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .