0

I'm currently writing the exposé to my thesis in texstudio and as I want to start the bibliography on a newpage I put \newpage after my last section. The last section ends on an even numbered page, but still when compiling there will be an empty page between my last section and the bibliography.

Openany in the documentdefinition seems to only work for the documentclass{book}, and neither the [oneside] option nor the command \let\cleardoublepage\clearpage change this behaviour. Thank you for trying to help. Lena

    \documentclass[10pt,a4paper,onesided]{scrartcl}
    \usepackage[ngerman]{babel}
    \usepackage{SIunits}
    \usepackage[utf8]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{setspace}
    \usepackage{color}
    \usepackage{breakcites}

 \begin{document}

    \begin{titlepage}
\begin{center}
 \onehalfspacing
\noindent \large info\\ Ort\\
Direktor\vfill


\noindent\LARGE \textbf{Thema} \\
\vspace{1cm}
\noindent\Large     Exposé über das geplante Promotionsvorhaben\par
\vspace{1,5cm}
\textbf{\today}
    \vfill

  \large Vorgelegt von \textit{Name}\\
   \vspace{0,5cm}
\onehalfspacing Im Rahmen der Dissertation\\
     zum Erwerb des Doktorgrades der Zahnheilkunde\\
      Betreuung durch\\
      Betreuer \par
\end{center}




\end{titlepage}
\onehalfspacing
\tableofcontents
\newpage
\section{Zentrale Fragestellung}
a\\
a\\ a\\ a\\ a\\ a\\ a\\ a\\ a\\
a\\ a\\ a\\ a\\ a\\ a\\ a\\ a\\ a\\ a\\ a\\
a\\  a\\ a\\ a


\section{Hintergrund}


a\\ 
a\\ 
a\\ 
a\\ 
a\\ 
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a
\begin{itemize}
    \item a\\ a

    \item a
    \item a\\a
    \item a
    \item a\\a
    \end{itemize}

\section{Stand der Forschung}

a\\ a\\
\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a 

\subsection{a}
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\

\subsection{b}
a\\a\\
\\
\noindent 
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a
\begin{itemize}
    \item a
    \item a

\end{itemize} 
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a

\begin{itemize}
    \item a
    \item a
    \item a
    \item a\\ a
\end{itemize}


\section{Zielsetzung}
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a

    \begin{itemize}
    \item a
\end{itemize}
\section{Versuchsaufbau und Methodik}
\subsection{Proben} 
 a\\
a\\
a\\
a\\
a\\
a\\
a\\
a

 \subsection{Versuchsaufbau}
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a

 \subsection{Eventuelle weitere Untersuchungen}
a\\
a\\
a\\
a\\
a\\
a\\
a\\
a\\ 


\samepage

\section{vorläufige Gliederung}
\setcounter{section}{0}
\section{Einleitung}
\section{Literaturübersicht}
\subsection{a}
\subsubsection{b}
\subsubsection{c}
\subsection{d}

\subsubsection{e}


\subsubsection{f}

\section{g}
\section{h}
\subsection{i}
\subsection{j}
\subsubsection{k}
\subsubsection{l}
\subsubsection{m}
\section{n}
\subsection{o}
\subsubsection {p}
\subsubsection{q}
\subsection{r}
\section{s}
\section{t}

\setcounter{section}{6}

\section{Ablauplan}

\newpage
\bibliographystyle{apalike} 
\bibliography{/home/lena/Dokumente/Uni/Doktorarbeit/Literatur/library.bib}



\end{document}
  • 2
    Welcome to TeX.SX! onesided is not a valid option for the scrartcl class. You should recieve a warning about an unused global option. Instead you maybe wanted to use oneside. – leandriis Aug 16 '19 at 8:04
  • 2
    Unrelated to your question, but regarding your use of SIunits: From CTAN about the before mentioned package: Note that the pack­age is now su­per­seded by siu­nitx; siu­nits has main­te­nance-only sup­port, now. So you ight want to consider switching to siunitx instead. – leandriis Aug 16 '19 at 8:05
  • 1
    Your example doesn't allow us to reproduce the problem. If I replace the bib with a local bib and run it I get only two pages. – Ulrike Fischer Aug 16 '19 at 8:07
  • 1
    don't use only long lists of headings like \section \subsection - there is no page break after them and so it can lead to overful pages (and so also to empty pages). Add some dummy text. – Ulrike Fischer Aug 16 '19 at 9:08
  • 1
    Instead of the long list of section headings in your section "vorläufige Gliederung" that will most likely contain a list of planned sections and subsections for the final thesis, you might switch to an enumerate list that does not exhibit the problem mentioned in the previous comment. – leandriis Aug 16 '19 at 9:11
0

This was too long for a note, and probably not an answer. I looked at the documentation of KOMA-script, page 148.

The default setting, where the bibliography is produced as an unnumbered chapter and does not receive an entry in the table of contents corresponds to bibliography=nottotoc. For more information, see the toc option in section 3.9, especially the bibliographynumbered, bibliography, andnobibliography values for this option on page 72.

You are using scrartcl\ and if the \section commands are redefined so the section commands produce a new page, also the bibliography probably will start on a new page.

Check what is happening when you remove the \newpage command.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.