4

The publisher is not listed when using the @article entry type, the natbib citation management package, and the plainnat bibliography style. How do I resolve this?

Here is an MWE. Note that "Elsevier" is not included in the typeset bibliographic entry:

enter image description here

\documentclass{article}
\usepackage{natbib}
\usepackage{filecontents}
\begin{filecontents}{sample.bib}
@article{woodford1990optimum,
  title={The optimum quantity of money},
  author={Woodford, Michael},
  journal={Handbook of monetary economics},
  volume={2},
  pages={1067--1152},
  year={1990},
  publisher={Elsevier}
}
\end{filecontents}

\begin{document}
\citet{woodford1990optimum}
\bibliographystyle{plainnat}
\bibliography{sample}
\end{document}
  • 4
    Welcome to TeX.se and thanks for including a minimal document! This is quite normal for most (all?) bibliography styles I know. Publisher information is used for books (single author and edited volumes) but not for journals. Do you have a specific style guide that requires it for journals? – Alan Munn Aug 19 at 18:47
  • Alan, thanks! Well, the "Handbook" is a book, so I would usually assume that it is good to list the publisher for anyone who wishes to find it. Is there a style file that does that? – Hal Aug 19 at 19:47
  • 1
    @AlanMunn - The main issue is that the OP was using an inappropriate entry type: The "Handbook of Monetary Economics" is not a journal. The real solution is to switch to the @incollection entry type. – Mico Aug 19 at 20:10
  • 1
    @mico This is why we need a broad range of academic specialists on the site! Not every problem is purely a TeXnical one. – Alan Munn Aug 19 at 21:09
3

It's a mistake to use the entry type @article for the entry at hand. The @article entry should only ever be used for pieces published in scholarly journals. That is decidedly not the case here: The "Handbook of Monetary Economics" is not, and has never been, a journal.

So, what to do? You really should be using the @incollection entry type. Changing the entry type to @incollection, changing the journal field to booktitle, and back-filling some missing fields (such as editor, chapter, and address), one gets:

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{sample.bib}
@incollection{woodford1990optimum,
  title     = {The optimum quantity of money},
  author    = {Woodford, Michael},
  booktitle = {Handbook of Monetary Economics, Volume~2},
  editor    = {Benjamin M. Friedman and Frank H. Hahn},
  chapter   = 20,
  pages     = {1067--1152},
  year      = {1990},
  publisher = {Elsevier},
  address   = {Amsterdam},
}
\end{filecontents}

\documentclass{article}
\usepackage{geometry} % optional
\usepackage[authoryear]{natbib} % or, if desired, use 'numbers' option
\bibliographystyle{plainnat}

\begin{document}
\nocite{*}
\bibliography{sample}
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.