0

The motivating question is actually this one.

I am still struggling to regenerate my Bison draft report from this Bismon github GPLv3+ software repository (using make latexdoc on Linux/Debian/Sid or Buster; see its README; that runs in about 3 seconds on a 4K€ Linux workstation, e.g. with AMD2970WX and 64 Gbytes RAM and SSD disk).

I am not, and don't have time or motivation, to become a LaTeXpert.

Is there any publicly available Web resources about LaTeX packages incompatibilities? I am not able to STFW for one.

A combinatorial approach to add/remove one by one every used package is untractable: I am using about 33 LaTeX packages (with a trial and error approach) and 233 tests is not reasonable.

Taking into account this excellent answer, my current git diff w.r.t. commit 54311004b61342cb311 (I am wrongly using git in some svn -like way, being the only git commiter) is just now

diff --git a/doc/bismon-chariot-doc.tex b/doc/bismon-chariot-doc.tex
index a81e131..51c815c 100644
--- a/doc/bismon-chariot-doc.tex
+++ b/doc/bismon-chariot-doc.tex
@@ -13,16 +13,16 @@
 \usepackage{fancyvrb}
 \usepackage{fancyhdr}
 \usepackage{fancybox}
-\usepackage{epsfig}
+%\usepackage{epsfig}
+\usepackage{graphicx}
 \usepackage{makeidx}
 \usepackage{float}
 \usepackage{xcolor}
-\usepackage{hyperref}
 \usepackage{moreverb}
 \usepackage{multirow}
 \usepackage{boxedminipage}
 \usepackage[square]{natbib}
-\usepackage{charter}
+%\usepackage{charter}
 %\usepackage{inconsolata}
 \usepackage{hevea}
 \usepackage{listings}
@@ -31,13 +31,14 @@
 \usepackage{filecontents}
 \usepackage{catchfile}
 \usepackage{lastpage}
-\usepackage{stmaryrd}
+%\usepackage{stmaryrd}
 \usepackage{ucs}
 \usepackage{stix}
 \usepackage{newunicodechar}
 % bigfoot enables \verb in footnotes
 \usepackage{bigfoot}
 \usepackage[a4paper, margin=2cm]{geometry}
+\usepackage{hyperref}

 \newcommand{\bmemail}[1]{{\href{mailto:#1}{\texttt{\textbf{#1}}}}}
 \newcommand{\bmurl}[1]{{\href{#1}{\texttt{\textbf{#1}}}}}
@@ -45,6 +46,7 @@

 % see also http://www.sascha-frank.com/Arrow/latex-arrows.html
 % and https://ctan.math.illinois.edu/macros/latex/contrib/newunicodechar/newunicodechar.pdf
+%U+21B3 DOWNWARDS ARROW WITH TIP RIGHTWARDS
 \newunicodechar{↳}{\rotatebox[origin=c]{180}{$\Lsh$}}

and it still does not work, since I am getting the same error

! Package ucs Error: Unknown Unicode character 8627 = U+21B3,
(ucs)                possibly declared in uni-33.def.
(ucs)                Type H to see if it is available with options.

See the ucs package documentation for explanation.
Type  H <return>  for immediate help.

but I am still spending too much time to fix my mistakes (because I don't know well enough LaTeX). Of course I did try (without success) to comment the \usepackage{ucs} line.

NB. Problem solved (as a code monkey, so not understanding why and how) in git commit 32752acf09a. Thanks for the suggestion to look inside the generated doc/bismon-chariot-doc.log file. It has more information that stderr+stdout gives.

  • 1
    This isn't a package incompatibility, it's an issue in your input; however, I'd avoid the ucs package. – Joseph Wright Aug 21 '19 at 9:44
  • It is a package incompatibility: I am trying (as a LaTeX code monkey) randomly various combinations of them. But 2 to the power 24 to 33 is too much tests because make latexdoc needs several seconds for a single run (on a 4000€ Linux desktop) – Basile Starynkevitch Aug 21 '19 at 9:45
  • And as told in the question, I did try to avoid the ucs package without success – Basile Starynkevitch Aug 21 '19 at 9:49
  • 3
    the error is not an incompatibility. You are using an input which needs additional code - standard latex does not provide definitions for the whole unicode. You need either an additional option for ucs, or (if you drop ucs) for inputenc, or you should use lualatex/xelatex (but this needs adjustments too). None of this can be done automatically without some latex skills. – Ulrike Fischer Aug 21 '19 at 10:09
  • 1
    well if you use lualatex you shouldn't use ucs. But this is not something you should "believe": check the log-file. – Ulrike Fischer Aug 21 '19 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.