2

Outlook and copy/paste of pdfcsplain run on the following file works well:

\input utf8lat1 \input lmfonts
ê é à
\end

Outlook and copy/paste of pdfcsplain run on the following file is broken:

\input utf8lat1 \input t1code \frlang \input lmfonts
ê é à
\end

Why?

(NOTE: recent csplain is used (Mar2019) where \frlang is enabled by default)

BTW: What means \oripdfoutput in csplain.ini? And why \xprncodes=0 is used in csenc-u.tex but \xprncodes are enabled in csplain.ini?

1
  • \xprncode has no effect when \mubytelog is equal to 1, so \xprncodes=0 in csenc-u.tex is redundant. As for \oripdfoutput, it seems it may have some application in document which uses csplain format. – Igor Liferenko Aug 26 '19 at 8:05
3

\input t1code must be before \input utf8lat1 because t1code does very basic settings, another macros (used in utf8lat1) depend on such settings. If you use \input t1code in csplain then this \input is recommended as very first \input in your document:

\input t1code \input utf8lat1 \frlang \input lmfonts
ê é à
\end

Note that this "obscurity" is here only when csplain is used in 8-bit TeX (like pdfTeX). If csplain is used in luaTeX or XeTeX then \input t1code nor \input utf8lat1 must be never used:

\frlang \input lmfonts
ê é à
\end
3

The issue can be reproduced without \frlang: it's t1code together with lmfonts.

The problem is that \cmaccents remains in force. Fix it by issuing \csaccents:

\input utf8lat1
\input t1code
\frlang
\input lmfonts
\csaccents

ê é à

\end

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.