2

I have just got feedback from my PhD transfer report and my supervisor has asked me to change my citation style (they don't use LaTeX so can't really help but there's no way I want to do a thesis in Word), having looked at the styles that can be used for biblatex and Biber and similar questions I still can't find a solution and don't fully understand how biblatex can be changed, it doesn't look as straight forward as writing a .bst file as for BibTeX.

The style they want is as follows, with citations with more than one author having "et al." and that being in italics and a comma before the date:

(Lodish et al., 2000) and (Morgan et al., 2003) and (Gray, 1918)

but using the code below I can only get these citations:

(Lodish et al., 2000) and (Morgan, Bayraktar, & Keaveny, 2003) and (Gray, 1918)

any help would be really appreciated!

\documentclass{article}
\usepackage[backend=biber, style=apa, citestyle=apa, maxcitenames=1]{biblatex}
\usepackage{filecontents}
\usepackage{hyperref}

\begin{filecontents*}{\jobname.bib}
    }
@Article{Morgan2003,
  author  = {Morgan, Elise F. and Bayraktar, Harun H. and Keaveny, Tony M.},
  title   = {Trabecular bone modulus–density relationships depend on anatomic site},
  journal = {Journal of Biomechanics},
  year    = {2003},
  volume  = {36},
  number  = {7},
  pages   = {897-904},
  issn    = {00219290},
  doi     = {10.1016/s0021-9290(03)00071-x},
  type    = {Journal Article},
}

@Book{Gray1918,
  title     = {Anatomy of the Human Body},
  publisher = {Lea \& Febiger},
  year      = {1918},
  author    = {Gray, H.},
  address   = {Philadelphia and New York},
  edition   = {Twentieth},
  type      = {Book},
}

@InBook{Lodish2000,
  title     = {22.3 Collagen: The Fibrous Proteins of the Matrix},
  publisher = {W. H. Freeman},
  year      = {2000},
  author    = {Lodish, H. and Berk, A. and Zipursky, S. L. and Matsudaira, P. and Baltimore, D. and Darnell, J.},
  type      = {Book Section},
  address   = {New York},
  edition   = {4th},
  booktitle = {Molecular Cell Biology},
  doi       = {https://www.ncbi.nlm.nih.gov/books/NBK21582/},
  url       = {https://www.ncbi.nlm.nih.gov/pubmed/},
}
\end{filecontents*}
\addbibresource{\jobname.bib}

\begin{document}

\parencite{Lodish2000} and \parencite{Morgan2003} and \parencite{Gray1918}

  \printbibliography
\end{document}
2
  • 2
    I'll have a closer look in a bit, but for now I should say that biblatex-apa is notoriously tricky to customise in some aspects. It was specifically written to implement the APA guidelines to the letter and there is only very limited support for deviations from APA rules. If you don't want APA style it is usually better to start from one of the standard styles.
    – moewe
    Aug 24 '19 at 10:35
  • Off-topic, but doi = {https://www.ncbi.nlm.nih.gov/books/NBK21582/}, url = {https://www.ncbi.nlm.nih.gov/pubmed/}, in Lodish2000 looks wrong. I guess url = {https://www.ncbi.nlm.nih.gov/books/NBK21582/}, and no DOI field would be better. Usually it is preferred to give the edition as bare number only with biblatex, so edition = {4}, in Lodish2000 and edition = {20}, in Gray1918.
    – moewe
    Aug 24 '19 at 10:38
1

As mentioned in the comments, biblatex-apa was specifically designed to implement the complex and comprehensive guidelines of citations and the bibliography from the Publication Manual of the American Psychological Association. As such the style can be tricky to modify even for small changes that "should be easy" and are easy in the standard styles. Therefore it is usually much better to start from one of the standard styles if you don't need APA style.

Your MWE also shows one of the issues with customisability of biblatex-apa: It doesn't respond to the maxcitenames option.

Since your desired citation style is very different from APA style it is probably best to switch to citestyle=authoryear,. I left in bibstyle=apa, even though I normally strongly recommend not to mix biblatex-apa with other styles since that is not intended use of the style (but it usually works).

Standard citestyle=authoryear, responds to maxcitenames as intended. I went for maxcitenames=2 because I don't like to abbreviate "Sigfridsson and Ryde" to "Sigfridsson et al.", but if you insist maxcitenames=1 will work as well. Standard authoryear doesn't have a comma between author and year, but you can get it with by redefining nameyeardelim. Options for italic "et al." are discussed in https://github.com/plk/biblatex/issues/899 (I chose the \DefineBibliographyStrings because that also works for biblatex-apa).

\documentclass{article}
\usepackage[backend=biber, bibstyle=apa, citestyle=authoryear, maxcitenames=2]{biblatex}
\usepackage{hyperref}

\DeclareDelimFormat{nameyeardelim}{\addcomma\space}

\DefineBibliographyStrings{english}{
  andothers = {\mkbibemph{et\addabbrvspace al\adddot}}
}

\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@article{Morgan2003,
  author  = {Morgan, Elise F. and Bayraktar, Harun H. and Keaveny, Tony M.},
  title   = {Trabecular bone modulus–density relationships depend on anatomic site},
  journal = {Journal of Biomechanics},
  year    = {2003},
  volume  = {36},
  number  = {7},
  pages   = {897-904},
  issn    = {00219290},
  doi     = {10.1016/s0021-9290(03)00071-x},
  type    = {Journal Article},
}
@book{Gray1918,
  title     = {Anatomy of the Human Body},
  publisher = {Lea \& Febiger},
  year      = {1918},
  author    = {Gray, H.},
  address   = {Philadelphia and New York},
  edition   = {20},
  type      = {Book},
}
@inbook{Lodish2000,
  title     = {Collagen: The Fibrous Proteins of the Matrix},
  chapter   = {22.3},
  publisher = {W. H. Freeman},
  year      = {2000},
  author    = {Lodish, H. and Berk, A. and Zipursky, S. L.
               and Matsudaira, P. and Baltimore, D. and Darnell, J.},
  type      = {Book Section},
  address   = {New York},
  edition   = {4},
  booktitle = {Molecular Cell Biology},
  url       = {https://www.ncbi.nlm.nih.gov/books/NBK21582/},
}
\end{filecontents*}
\addbibresource{\jobname.bib}
\addbibresource{biblatex-examples.bib}

\begin{document}
  \parencite{Lodish2000}
  \parencite{Morgan2003}
  \parencite{Gray1918}
  \parencite{sigfridsson}

  \printbibliography
\end{document}

(Lodish *et al.*, 2000) (Morgan *et al.*, 2003) (Gray, 1918) (Sigfridsson and Ryde, 1998)

Please note the small changes compared to your .bib entries.

4
  • I chose apa because it seemed to be close to what I wanted but I agree authoryear would be better, also thank you so much for your help with editing the style!
    – Kern
    Aug 25 '19 at 11:44
  • @Kern Yes, this happens quite often. The standard styles have some idiosyncrasies that people dislike and while APA style has other idiosyncrasies on a superficial level it often seems to be closer to what people hope to get. The problem the is that while the standard styles can be configured to change their idiosyncrasies (\begin{ad} even more so with biblatex-ext \end{ad}), biblatex-apa is quite rigid.
    – moewe
    Aug 25 '19 at 13:14
  • @Kern If this answer solved your problem and answered your question, you may want to consider accepting it. See tex.stackexchange.com/help/someone-answers and tex.meta.stackexchange.com/q/1852/35864.
    – moewe
    Aug 25 '19 at 13:15
  • Sorry I am new to stackexchange so wasn't aware of accepting answers, it should be accepted now! Thanks again
    – Kern
    Aug 26 '19 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.