3

I am using package bibtopic to display multiple bibliographies in a single document.

\documentclass[a4paper,11pt]{article}
%\usepackage{natbib,hyperref}
\usepackage{bibtopic} % For multiple bibliographies

%\setlength{\bibsep}{6pt} % Space between entries
\bibliographystyle{is-unsrt}

\begin{document}
...
    \subsection*{Some heading}
        \begin{btSect}{BookList1}
        \btPrintNotCited
        \end{btSect}
...
    \subsection*{Some other heading}
        \begin{btSect}{BookList2}
        \btPrintNotCited
        \end{btSect}
...
\end{document}

While using the package natbib, I used to set the space between individual bibliography entries with line \setlength{\bibsep}{6pt}. Under package bibtopic, that is not effective.

How can I set the space between individual bibliography entries under package bibtopic?

3
+50

The manual of bibtopic states that the package is compatible with natbib. So the following code sets the space between entries to 24pt:

\documentclass[a4paper,11pt]{article}
\usepackage[numbers]{natbib}
\usepackage{bibtopic} % For multiple bibliographies

\setlength{\bibsep}{24pt} % Space between entries
\bibliographystyle{is-unsrt}

\begin{document}
...
    \subsection*{Some heading}
        \begin{btSect}{books}
        \btPrintNotCited
        \end{btSect}
...
    \subsection*{Some other heading}
        \begin{btSect}{articles}
        \btPrintNotCited
        \end{btSect}
...
\end{document}

enter image description here

Note that you need to use the numbers option for natbib if you want to use a numeric bibliogaphy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.