1

I have the following error while compiling my memoir. Here is a MWE that also gives this error:

\documentclass[b4paper,14pt,english,twoside]{memoir}
\usepackage[english]{babel}
\usepackage[utf8]{inputenc} % For Fappendixrench accents
\usepackage[T1]{fontenc}
\usepackage{lmodern, textcomp}
\usepackage{fixcmex} %fixing lmodern and textcomp

\usepackage[usenames,dvipsnames,svgnames,table]{xcolor}


    \usepackage{biblatex}
    \usepackage{hyperref}
    \hypersetup{
    colorlinks = true,
    linkcolor = blue,
    linkbordercolor = {white},
    citecolor = blue,
    }

    \addbibresource{References.bib}
   %  \AtBeginBibliography{%
   % \renewcommand*{\mkbibnamefirst}[1]{\mkbibbold{#1}}%
   % \renewcommand*{\mkbibnamelast}[1]{\mkbibbold{#1}}%
   % \renewcommand*{\mkbibnameprefix}[1]{\mkbibbold{#1}}%
   % \renewcommand*{\mkbibnameaffix}[1]{\mkbibbold{#1}}%
   % }


    \begin{document}
      \section{test}
    % \bibliographystyle{IEEEtran}
    % \bibliography{References}
    \printbibliography
    \end{document}

Running 'biber  "Memoir-DS_Julien"'
------------
INFO - This is Biber 2.12
INFO - Logfile is 'Memoir-DS_Julien.blg'
INFO - Reading 'Memoir-DS_Julien.bcf'
ERROR - Error: Found biblatex control file version 3.6, expected version 3.5.
This means that your biber (2.12) and biblatex (3.13) versions are incompatible.
See compat matrix in biblatex or biber PDF documentation.
INFO - ERRORS: 1
Biber error: [131] Utils.pm:209> ERROR - Error: Found biblatex control file version 3.6, expected version 3.5.

References.bib:

  @article{roy1973methode,
  title={La M{\'e}thode ELECTRE II(Une application au m{\'e}dia-planning...)},
  author={Roy, Bernard and Bertier, Patrice},
  year={1973},
  publisher={Metra international}
}

I know this is duplicate but I couldn't find any working solutions in the following questions:

How can one install biber on miktex 64-bit?

Install Biber in MiKTeX on a 64-bit version of Windows

I am learning LaTeX by my own so this error is a bit harsh for me to correct. I've tried to reinstall biber and biblatex. I've tried to install a new version of biber (2.13) thanks to a local texmf tree as well, but that didn't work. Biber is still under 2.12, I don't know why.

What should I do? How to check if I miss-installed biber 2.13? I'm on windows 10 64bits, I use MikTeX 2.9 and I compile thanks to the following command:

latexmk  -shell-escape -pdf ./Memoir-DS_Julien.tex
  • 1
    Each biber works with specific biblatex and vice-versa (with different version numbers). As you use MikTeX, the best solution consists in updating both biber and biblatex files to the latest versions, by using the MikTeX console (mpm), and ensure that you put them in the main texmf tree under C:\Program Files\MiKTeX 2.9\... – Jhor Aug 27 '19 at 13:20
  • 1
    Of topic: linkbordercolor = {white}, is useless as soon as colorlinks is set to true. – Jhor Aug 27 '19 at 13:26
  • 1
    I just tested: miktex install the correct biber 2.13. A small document compiles fine. So you made an installation error. Start the miktex console, normally it should ask you if you want to use admin mode. miktex.org/howto/miktex-console. And try to update. – Ulrike Fischer Aug 27 '19 at 14:23
  • 1
    Please remove all manually installed Biber and biblatex versions that you downloaded on your PC in the cause of trying to fix this issue. Make sure the biblatex and Biber packages are installed in MikTeX. Then update MikTeX as described in tex.stackexchange.com/q/55437/35864. If you have a multi-user installation make sure to run the updater in Admin and User mode (this is explained in the linked post with images). ... – moewe Aug 27 '19 at 19:02
  • 1
    ... For the time being ignore that the MikTeX package manager says it is installing Biber 2.12. This is a bug with the version number in the catalogue, not with the version actually installed on your system. (github.com/MiKTeX/miktex-packaging/issues/126) Just make sure you have updated your system properly and completely. Then remove all temporary files (.aux, .bbl, .bcf, ...) and recompile from scratch with LaTeX, Biber, LaTeX, LaTeX. – moewe Aug 27 '19 at 19:03
2

Before we start Do not update biblatex or Biber manually.

All big TeX distributions ship biblatex and Biber in matching versions so that usually things should work out just fine it you update your packages via the usual means of your TeX distribution. See How do I update my TeX distribution?.

If you are using MikTeX, keep in mind that you may have to run the updater in user and admin mode (this is explained in the linked question in more detail with pictures).

In case you tried to update biblatex or Biber manually, remove all the files from those attempts and let your TeX distribution figure things out.

In the rare event that your TeX distribution indeed does not ship matching versions of biblatex and Biber alert the maintainers (TeX live via the mailing list https://tug.org/mailman/listinfo/tex-live and MikTeX on GitHub https://github.com/MiKTeX/miktex-packaging/issues), issues like this are usually fixed very quickly.

After a biblatex/Biber update you may have to remove temporary files (.aux, .bbl, .bcf, ...) for a smoother experience, since those files can contain version-specific definitions.

A few days ago there was a tiny glitch in the MikTeX package database. The version information of the Biber packages (for example https://miktex.org/packages/biber-windows-x64) says "2.12", but the binaries that are installed are version 2.13. This has been reported at https://github.com/MiKTeX/miktex-packaging/issues/126 and was resolved a few days later. But it was only a cosmetic issue, it did not impact functionality at all, since the correct version of Biber was distributed, just the package info was incorrect.

0

You can download an uptodate version of biber (v 2.13) from the links on https://ctan.org/pkg/biber And install it manually.

  • I actually tried to do it. From this page http://biblatex-biber.sourceforge.net/ more precisely. I tried adding biber.exe in my local tree, (see posts for question links) but that didn't change my compile error – JKHA Aug 27 '19 at 14:04
  • 3
    That is probably not a good idea as it might not be the official release version – daleif Aug 27 '19 at 14:07
  • 3
    @JKHA It doesn't make sense to add biber.exe to your local tree. That's an application so it should be in your path (and before the miktex/bin/ path). – Ulrike Fischer Aug 27 '19 at 14:16
  • Ok, I did look at the the refred posts but their are fairly obsolete ! Does the error message still says "This is Biber 2.12". In the positive case, it means that your new biber is not invoked. You should ensure that the new one (1) either is installed in the main tree or (2) that your local texmf is in system path before the main one. As I suggested in a previous comment, and as @Ulrike Fisher added in her comment – Jhor Aug 27 '19 at 14:25
  • 2
    Installing Biber manually should only be a last resort. I would even go as far as saying that the average user should never update Biber or biblatex (or indeed any package manually). Let the TeX distribution figure that out. – moewe Aug 27 '19 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.