1

I use biber for citations as follows:

\usepackage[
    backend=biber,
    style=authoryear,
    natbib=true,
    url=false, 
    doi=false,
    eprint=false,
    maxbibnames=99
    ]{biblatex}

\renewbibmacro*{name:andothers}{% Based on name:andothers from biblatex.def
    \ifboolexpr{
        test {\ifnumequal{\value{listcount}}{\value{liststop}}}
        and
        test \ifmorenames
    }
    {\ifnumgreater{\value{liststop}}{1}
        {\finalandcomma}
        {}%
        \andothersdelim\bibstring[\emph]{andothers}}
    {}}

\addbibresource{bib/refs.bib}

And I have in my refs.bib two differnet authors with the same name. Biber now alwas prints something like this: (D. Name et al., 2017) when using \parencite(Name2017). If I \parencite() an author with a unique surname I only get (Name et al. 2017). How do I change the setting of biber to get alwas only (Name et al. 2017), no matter how often this name is in my bibliography?

Thanks for any help!

marked as duplicate by moewe biber Sep 7 at 5:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

add uniquename=false to package options:

\usepackage[
    backend=biber,
    style=authoryear,
    natbib=true,
    url=false, 
    doi=false,
    eprint=false,
    maxbibnames=99,
    uniquename=false,
    ]{biblatex}
  • I got rid of the first letter but now I get the names of the first two authors: (Name, Name, et al., 2017)... can I change this too? – lefrcom Aug 28 at 11:48
  • @lefrcom Unfortunately, we can't say with certainty what that is. My best guess is uniquelist, but it might be something else. – moewe Aug 28 at 15:48
  • @moewe, thanks uniquelist=False together with uniquenames=False works perfectly for me! Thanks. – lefrcom Aug 30 at 13:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.