3

I'm trying to build a tex file with TeXstudio 2.3 (and MikTeX 2.9 installed separately), which builds with no problem using LEd. When I run pdflatex with TeXstudio, I get the error message (and thus the .pdf is not generated):

Process started: "C:/Program Files/MiKTeX 2.9/miktex/bin/pdflatex.exe" -synctex=1 -interaction=nonstopmode "project".tex

pdflatex.exe: The MiKTeX web service has rejected your request. Possible reason: too many requests arriving from your IP address. pdflatex.exe: Data: 
pdflatex.exe: Data: 
ERROR
pdflatex.exe: Data: 
Access Denied
pdflatex.exe: Data: 

pdflatex.exe: Data: 
pdflatex.exe: Data: 
pdflatex.exe: Data: pdflatex.exe: Data: Access Denied by security policy pdflatex.exe: Data: pdflatex.exe: Data: 
pdflatex.exe: Data: 
pdflatex.exe: Data: The security policy for your network prevents your request from  pdflatex.exe: Data: being allowed at this time. Please contact your administrator if pdflatex.exe: Data: you feel this is incorrect. pdflatex.exe: Data: 
pdflatex.exe: Data: pdflatex.exe: Data: 
Process exited normally

Also, I run pdflatex on command line, and it generates the .pdf with no problem (no policy problem), and the pdflatex command is configured as

pdflatex.exe" -synctex=1 -interaction=nonstopmode %.tex

Should I configure something to fix this?

2

I had a similar problem when I started using Latex, Textstudio, and Miktex. If both programs are the newest version, make sure that you install Miktex before Textstudio. I made a mistake by installing Miktex and Texmaker and then uninstalled Texmaker and switched to Textstudio. After that, Textstudio would work in some respects but not others. I uninstalled both and then re-installed Miktex first. Now everything works just fine. I am not sure if there is an easier way to configure this, but that seems to be the general advice I see about issues like this.

Cheers

1

Try with this pdflatex command

pdflatex -synctex=1 -interaction=nonstopmode %.tex

there should not be " character in your question. May be that might create the problem.

1

I had a similar issue. Consider reinstalling. I had Protext installed as a 32bit, but had Miktex installed as a 64 bit. After installing properly and having both programs agree, you may check that they are both located in the same program folder. I don't know why there is not a all in one version, considering Miktex is compulsory to have to run Protext.

0

Verify that "-synctex=1" in the PdfLateX command. If it is, make sure that you install TeXstudio after installing MikteX as Mike Stumpf said. This was my problem (I couldn't sync even if my synctex was set to 1). P.S. Don't forget to save your profile and settings if you have already customized your TeXstudio environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.