1
pandoc Article.tex --from=latex --to=docx --biblatex --bibliography="bibliography.bib" --output=Article.docx

As per tex to docx via pandoc with ACM template

Fails to actually produce the bibliography.

What I am missing in the command line?

MWE

\documentclass[12pt]{article}
\usepackage[utf8]{inputenc}
\usepackage[T1,T2A]{fontenc}
\usepackage[english,french,german,italian,russian]{babel}
\usepackage{csquotes}
\usepackage{calc}
\usepackage{hyphenat}
\usepackage[backend=biber,style=gost-footnote,language=auto,autolang=other,autocite=footnote,citetracker=true,ibidtracker=false,opcittracker=false,sorting=nyt,notetype=foot+end]{biblatex}
\usapackage{filecontents}
\addbibresource{bib}

\begin{filecontents}{bib}

@Book{Woolf:1913,
  author      = {C. N. S. Woolf},
  title       = {Bartolus of Sassoferrato: His Position in the History of Medieval Political Thought},
  address     = {Cambridge},
  publisher   = {Cambridge University Press},
  year        = {1913},
  language    = {english},
  hyphenation = {english},
}

\end{filecontents}

\begin{document}

\autocite{Woolf:1913}

\end{document}
3

After fixing some minor issues in your MWE, the following works:

\documentclass[12pt]{article}
\usepackage[english,french,german,italian,russian]{babel}
\usepackage{csquotes}
\usepackage{calc}
\usepackage{hyphenat}
\usepackage[backend=biber,style=gost-footnote,language=auto,autolang=other,autocite=footnote,citetracker=true,ibidtracker=false,opcittracker=false,sorting=nyt,notetype=foot+end]{biblatex}
\usepackage{filecontents}
\addbibresource{Article.bib}

\begin{filecontents}{Article.bib}

@Book{Woolf:1913,
  author      = {C. N. S. Woolf},
  title       = {Bartolus of Sassoferrato: His Position in the History of Medieval Political Thought},
  address     = {Cambridge},
  publisher   = {Cambridge University Press},
  year        = {1913},
  language    = {english},
  hyphenation = {english},
}

\end{filecontents}

\begin{document}

\autocite{Woolf:1913}

\end{document}

Call:

pandoc Article.tex \
    --from=latex --to=docx \
    --filter=pandoc-citeproc --bibliography=Article.bib \
    --output=Article.docx

Which gives you:

enter image description here

If you need a different citation style, download the right .csl-file from Zotero Style Repository and add the option --csl=filename.csl

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.