2

I'm constructing a thesis by paper submission and I would like to include a PDF article submission without including these pages in the page count.

The numbering within the PDF is Arabic, so the pages before and after must be roman.

Currently I have:

  • An unnumbered title page
  • Pages numbered i to iv before \includepdf{Paper.pdf}
  • The included pdf, already numbered 1 to 28.
  • Pages numbered xxxv to xxxviii (I would like this to be vii to x)

I have tried:

\pagestyle{empty}  

\includepdf{Paper.pdf}

\pagebreak

\pagestyle{plain}  

\setcounter{page}{7}  

\pagenumbering{roman}

However, this just starts the roman numbering from 1 again... Other variations seem to eliminate the post-PDF numbering altogether.

Based on answers to other similar questions I assume I'm not far off, but I can't seem to get it.

1
  • 2
    Welcome to tex.sx. Try moving the \setcounter instruction after the \pagenumbering{roman}. Commented Aug 29, 2019 at 13:59

1 Answer 1

3

You have to look at what \pagenumbering actually does in order to understand why (from the LaTeX kernel):

\def\pagenumbering#1{%
  \global\c@page \@ne % <---------------------------- 1
  \gdef\thepage{\csname @#1\endcsname \c@page}}% <--- 2

Note how \pagenumbering{<scheme>} does two things:

  1. Globally (re)sets the page number counter \c@page to 1;
  2. Globally (re)defines \thepage to be a representation of the page counter according to <type>. Here <scheme> is defined as a macro \@<scheme>. So, \pagenumbering{roman} results in \@roman.

Your approach sets the page number to 7 via

\setcounter{page}{7}

but this is reset to 1 with a call to

\pagenumbering{roman}

You should just be able to drop the \pagenumbering call as \includepdf{...} should include the document without setting anything in the header/footer. However, if that doesn't suit you, you can always be verbose with

\pagenumbering{roman}
\setcounter{page}{7}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .