I need the webomint font, but when I try to compile a document with it I get the following error:

! LaTeX Error: File `webomints.sty' not found.

I know that it means that LaTeX doesn't find the package, so I looked around and I found out that some fonts must be installed separately and that webomints is one of them. I tried to install them in several ways, none of which worked for me, so I tried to compile a minimal document to be sure that the problem wasn't due to other packages doing strange interactions, but nothing changed.

I tried to install the package in the following ways:

Through getnonfreefonts

I installed getnonfreefonts and run sudo getnonfreefonts --sys --all and rebooted the computer but pdflatex still gave me the error. When I run sudo getnonfreefonts --sys --lsfonts I get the following output, so I suppose that the package is installed:

me@mypc:~$ sudo getnonfreefonts --sys --lsfonts
--2019-09-01 15:24:05--  https://www.tug.org/~kotucha/getnonfreefonts/getfont.pl
Risoluzione di www.tug.org (www.tug.org)...
Connessione a www.tug.org (www.tug.org)||:443... connesso.
webomints      Webomints (Galapagos Design Group)                   [installed]

Through "manual way"

I tried to follow the Installation instructions provided by CTAN, but I couldn't find the directory fonts/tfm/public/misc

Other ways

I also followed suggestions from other Q&A posts, both from Stack Exchange and other websites, none of which worked for me. I'd like to add some links but I don't remember them; however, I just asked to Google something like "LaTeX install webomints" and so on.

I am working in Ubuntu 19.04 (Disco Digo): an OS specific answer, if necessary, would be appreciated. I have full root access, so I can do everything I have to do to make the stuff work.

Please else consider that I am quite new to both Ubuntu and LaTeX.


@daleif These is exactly what I get when I launch the commands you asked for (except for user an pc names, which I obscured):

me@mypc:~$ kpsewhich article.cls
me@mypc:~$ sudo updatedb
[sudo] password di me: 
me@mypc:~$ locate webomints.sty

locate webomints.sty does not output anything, which I suppose is not a good news...

I use TeX Live, which I installed following the instructions from tug.org and acquiring it "over the internet" (using the net install).

  • From a terminal can you tell us what output kpsewhich article.cls gives? Also with locate webomints.sty (the latter might need sudo updatedb) first. The first command we use to get a little information about your latex system. The latter a little information about where webomints may have gone. You never told us what latex you actually have installed. Is it a latex from Ubuntu or something else. I use something else and I actually don't know what happens if you use getnonfreefonts on an Ubuntu latex (there might be small differences)
    – daleif
    Sep 1, 2019 at 17:17

1 Answer 1


The webomints package does not include a sty file, as can bee seen on CTAN. Instead you can look at the provided sample files for inspiration. In essence you only have to state that you want to use the appropriate font. And the call to getnonfreefonts was (most likely) sufficient to get that going:


{\usefont{U}{webo}{xl}{n} ABCD EFGH IJKL MNOPQRST UVWXYZ}


enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .