Last year, I could make movie15 work in my powerdot presentations, through the dvi2ps ps2pdf route. I re-visited recently and could not get the movies (*.wma) to appear anymore. I spent the better part of two days trying to understand media9 as its replacement, and I can get the two to work independently, but not together (At least not real, pretty like). Has anyone successfully accomplished this, or is there a reason this will probably not work?

I converted my WMA to MP4, and if I go the dvipdf route, using media9 in either an article class or a powerdot class, I get the movie to show up correctly, however, while the article class "looks" right, the powerdot class PDF only covers the bottom 1/4 of the pdf page.

If I go the dvi2ps and ps2pdf (GS 9.05) the powerdot and the article class both look right (takes the entire page), but the movie doesn't show up in either one. I can post specifics, but I thought I would get the big picture answer that it is indeed possible. I've tried most of the suggestions I have found (i.e. -dNOSAFER), but no luck!

Response to Alexander: Excellent, at least now I know someone has it working and its just a matter of the right format/order of 1s and 0s. I have a pretty similar setup, and when I ran your code, I got a:

'powerdot-default.ps' not found. 

So I added a style option:


and then got the error:

! Package babel Error: You haven't loaded the option english yet. 

So I added: \documentclass[style=simple, language=english]{powerdot}... (Just in case anyone receives these errors, a work around for me until I find the right problem).

Finally I got a StrobeMediaPlayback.swf not found, probably because I do not have it installed (did it come with v0.3?) I just have the original VPlayer.swf. So I will try and find StrobeMediaPlayback.swf since I am still in the same boat, the PDF looks great (formating wise), but the movie still is not there... do I have to manually update to v0.3? I thought I was setup for automatic updating, but maybe not.

Could I ask what your switches/parameters are for dvi2ps and ps2pdf?

  • StrobeMediaPlayback.swf is included in media9 since yesterday. If you use TeXLive, try an update (tlmgr update --all). It may take a day for updates to be propagated to the mirrors. The second error is due to babel. Delete *.aux to make it go away and recompile. The first error doesn't have to do with media9, no idea what might be the reason for it.
    – AlexG
    Commented Apr 4, 2012 at 12:17
  • It's called dvips here. Don't use any option with it. The same for ps2pdf.
    – AlexG
    Commented Apr 4, 2012 at 12:19
  • MiKTeX package updates usually happen only once per week, unfortunately.
    – AlexG
    Commented Apr 4, 2012 at 12:24

1 Answer 1


I wouldn't use movie15 any longer. Once you have all your video files converted to or rebuilt as MP4, media9 should do. The example below using the powerdot class and media9 (v0.3, uploaded yesterday) worked for me. The video file was copied from $TEXMF/doc/latex/media9/files into the working directory. ps2pdf option -dNOSAFER is not required with media9.

\usepackage[UKenglish]{babel} %media9.sty needs it, language doesn't matter


\begin{slide}{Embedded video}

    width=200pt, height=150pt,


  • Yep, got the StrobeMediaPlayback.swf through the new package today and solved all my ills (as well as deleting the aux file!) for the dvips ps2pdf route. Still not sure what is causing the powerdot-ps problem, but the work around is working so I am not bothered. Thanks, great product!! Oh, and the dvi2ps term is from WinEdt (I was pulling hair out changing the options for the executable I just brain washed myself...) Thanks again.
    – Biaspoint
    Commented Apr 4, 2012 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .