I did not know that latex had different symbol for opening and closing quotation marks. I've used it like "abc" every where and just realised that I really should have used ``abc". Is there anyway I can convert all the quotations to become like ``abc"? Doing it manually will take forever as I have a lot of quotations.

  • 3
    You could just use sed for this (sed is awesome). It does require some escaping on the command line, since you are trying to replace quotes. I can't put it in here, since it contains backticks. So a link will have to do. – Roelof Spijker Apr 4 '12 at 12:28
  • On an unrelated note, a lot of editors will automatically replace " with the correct quotation form when you type the character. I know for a fact kile does this, and I believe AUCTeX does so as well. – Roelof Spijker Apr 4 '12 at 12:31
  • 1
  • @RoelofSpijker There are some advantages in NOT using the auto-replace-feature: tex.stackexchange.com/questions/39285/… – matth Apr 8 '12 at 20:14
  • @matth: I completely agree. In my academic writings I (pretty much) never use quotes. The only time I use them is when passing a literal string to the pgf math engine and in that case I need actual quotes, not the converted ones. Which mostly ends up in me typing \" and then removing the ``. This doesn't happen often enough for me to disable the autoreplace though. I know what I want in what case and how to obtain it. If you are using mostly quotes as in quotations it's an option though :) – Roelof Spijker Apr 8 '12 at 23:54

An alternative to quotes is csquotes from 2011, while quotes is from 1997 …



Hello "World"!
  • Ack, I knew this was too good to be true: Package csquotes Error: ucs package not supported – Alec Jacobson Sep 25 '18 at 4:50

The package csquotes has many more goodies than the one mentioned. If you use the command \enquote{. . .}, you can nest several levels of quotations, while LaTeX preserves the correct couples of signs. You can even set localization preferences in order to use the proper signs for a language.

For instance, \enquote{\enquote{This is a quote within a quote}} will be rendered as:

“‘This is a quote within a quote’”

(with a thin space in between the contiguous signs).

But if you load the csquotes package thus (as I usually do):

\usepackage[autostyle=false, style=british]{csquotes}

the previous code will be rendered thus:

‘“This is a quote within a quote”’

See the documentation of the package for further details (texdoc csquotes).


There is a package for this: quotes. With this package, "text" is typeset correctly as ``text''.

  • 10
    The package quotes is very simplistic. I'd recommend csquotes instead. – egreg Apr 8 '12 at 15:39

Edit 2 solution suggested by Boris seems to be the easier way.

Depending on which editor you use you can perform a search an replace. You would be searching for


(replace the underscore with a white space, its just there to make my point) and then replace it by


again, the underscore stands for a white space.


As David Carlisle pointed out that you should also change the right quote to '' so you get the proper right quote.

However there you have to account for the following characters after the right quote. I know no better way than trying to think of all possibilities (I can think of 4 that are likely)

"_ %your quote is followed by a white space
". %your quote is followed by a period
", %your quote is followed by a comma
"! %your quote is followed by an exclamation mark

then replace each of them with their respective version



Edit 3 MWE with quotes package

% !TEX encoding = UTF-8 Unicode


\noindent "test" \\
  • 4
    Note that in addition to changing the left quote to `` ` `` you should change the right one to '' it is only by accident, and only in some encodings, that the input of " produces the right double quote ligature. – David Carlisle Apr 4 '12 at 12:27
  • I tried:\usepackage{quotes} ...... "MyWord" .... but it still making opening curly quote back-ward direction I am using Mac OS X, Standard US english Key-board. I have written full document using TexShop. An did not use underscore...so that I do find and replace as suggested by @Philipp....... Any help please? – khademul Apr 4 '12 at 13:29
  • I tried a MWE with the quotes package and it works fine. I added the MWE to my answer at the end. – Philipp Apr 4 '12 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.